I have been sent an encrypted .docx file as it contains confidential information, but I am on linux.

I have the password, but OpenOffice.Org doesn't seem to even recognize that it is an encrypted file and give me an option to decrypt it.

I thought microsoft might have provided a utility for this at least, I even tried Office Web Apps, but I guess they don't expect this problem to come up all that often.


what is your open office version ? I think the handling of the password encrypted files has been implemented on version 3.2. If you have an earlier version, you might consider updating it. I have never been in your situation, i.e., been handed a password encrypted file to work with. So, my knowledge is coming from an older post on a forum. Hope it helps.

  • Thanks for the answer, Mel, but I am using version 3.4.1. See my comment on orcmid's answer. – Luke Mar 29 '13 at 0:43
  • 1
    have you considered possibility that the document might be corrupt ? if you have access to a computer with MS word installed, see if you can open it there. While you are at it, create another document with encryption and test that one on your open office. Otherwise it is puzzling. – MelBurslan Mar 29 '13 at 0:58
  • I managed to get it open with Office, so it isn't corrupted. – Luke Mar 30 '13 at 15:28
  • There are two things to consider. First, the discrepancy may be between Linux and Windows install of Apache OpenOffice 3.4.1. Secondly, if the file was produced by Office 2013 (while unlikely at this point in time), it might not be something that Apache OpenOffice 3.4.1 can open even though Office 2010 can open it. – orcmid Apr 16 '13 at 15:59
  • I suspect the first case is more likely, because you don't even get to the point where the password for decryption is requested. Can you have someone encrypt a trivial document with a different password that also exhibits the problem? Then the AOO team can see what's failing. – orcmid Apr 16 '13 at 16:06

I was able to create an encrypted .docx in Microsoft Office 2007 Word and open it in both Apache OpenOffice 3.4.1 and LibreOffice 4.0.1.

  • I am using OpenOffice 3.4.1, and on selecting either of the Microsoft Word 2007 XML or Microsoft Word 2007 Binary file types a window comes up saying there is a General Input/Output Error. It is literally no more descriptive than that. – Luke Mar 29 '13 at 0:42
  • Luke, .docx is neither of those. It is OOXML. You should just be able to select it for Opening without specifying its file type and Apache OpenOffice 3.4.1 will immediately ask you for the password. If that doesn't work, let me know. There may need to be a bug against the Linux release. Make sure you download from www.openoffice.org, too. – orcmid Mar 29 '13 at 23:36
  • I don't see an option for OOXML in the list of filters. I did download directly from openoffice.org. – Luke Mar 30 '13 at 0:20
  • I remembered I had Office 2010 Starter Edition on my Windows partition, so I gave that a try and it worked... However, I will be getting more of these in future and I would prefer not to have to rely on Windows which runs really slowly on this machine. – Luke Mar 30 '13 at 15:29
  • In Apache OpenOffice 3.4.1, the format to select is "Microsoft Word 2007 XML (.docx, .docm)." That is called Microsoft Word 2007/2010 XML" in LibreOffice 4.0.1 which also supports "Office Open XML Text (*.docx, *.docm). That last is presumably the strict OOXML supported by Office 2013 (and also read by 2010 but not written by Office 2007/2010). – orcmid Apr 15 '13 at 19:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.