1

I have two Excel (.xls) files that I'm comparing using Beyond Compare 3. When a record is different, it's messing up the alignment, and it doesn't fix itself for several records, so I'd like to manually realign the compare. According to their help, I right-click on a line and choose align. Except that align isn't on the right-click menu. Why?

I'm comparing as 'Detected (MS Excel Workbooks)', Showing All.

2

You shouldn't need to do manual alignment when doing a data compare: simply select which columns are 'key' columns, and BeyondCompare will do the rest (auto-align based on that).

That's a better option than having to do manual realignment, since it can cope with the entire data set being sorted differently.

(@thursdaysgeek is technically correct that the 'Align With' option is missing (because of this), but I think missed the key point here - this is one of those questions where the OP is asking how to do the wrong thing (no offence intended))

  • I had hinted at that in my answer to myself, but you explained it more clearly -- I was asking how to do something I shouldn't do. – thursdaysgeek Sep 16 '14 at 16:34
2

It's even easier than that. All you have to do is close the original "Data Compare" window, select the two files to compare in the "Folder Compare" window (hold down the "Ctrl" key to multiselect), then right-click on your selection and select "Open With|Text Compare".

1

I found this post Align with option not available unless using text based files in the Scooter Software forums. It essentially tells me that alignment doesn't work for non-text files.

I found two workarounds:

  1. Save my Excel files as text and then compare them.
  2. Change the field used as a key field.

The second workaround was easier, and in my case, made the alignment no longer an issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.