5

I have a apple computer, and am running the apple operating system within a VM on that machine. The VM is running with VMWare.

How do I send keyboard combos that use the command key to the VM? When I use the command key with the VM open, fullscreen or not, the keyboard combination always goes to the host instead of the VM. So, for instance, if I hit command-Q then the entire VM closes instead of the program I have open in the VM.

(The VM does have the VM client tools installed)

Its really killing me to having to mouseclick everything in the VM.

4

Just had to figure this out myself.

Click the Wrench icon or choose Settings from the Virtual Machine Window. Click "Keyboard and Mouse" and choose the Mac profile.

I also had to reboot my VM afterwards.

6

You just use the Windows key: Using Mac Keyboards in a Virtual Machine

  • It is a MAC VM running on a Mac host. What window key are you referring to? – Frank Schwieterman Mar 28 '13 at 23:59
  • What are you using to access the Mac VM? – Dion Pezzimenti Mar 29 '13 at 0:27
  • I'm sorry I may not understand your question- I'm using VMWare Fusion to run the VM. The host is a laptop, I'm typing on its keyboard. – Frank Schwieterman Mar 29 '13 at 1:14
1

I also think your answer lies in the keyboard & mouse settings. I had myself a slightly different problem: I found a ready-made VM and all was working except command-clic. The solution was also there: when you double-clic "Mac profile" in the keyboard & mouse settings, you have to disable "Button 3" to have command-clic working (at least in my case). Hope this may help someone. :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.