1

Originally installed Windows 8 (non-UEFI install) with a GA-Z68MA-D2H-B3 motherboard.

After upgrading the BIOS to a UEFI version and enabling some fast-boot settings and Windows 8 integration, the system boots to the OS extremely fast. However, I found that the "UEFI Firmware Settings" option is missing from the Windows advanced startup options. Also note, boot loader path is \Windows\system32\winload.exe.

Is there a method that allows for changing/enabling the UEFI Firmware Settings menu entry?

I'm even willing to reinstall the OS, though I also can't seem to boot from CD/DVD at this point.

2

If you're currently booting in BIOS/CSM/legacy mode, you can convert to an EFI/UEFI-mode boot by installing a suitable EFI-mode boot loader. This process is described here, but be aware that this page is geared toward using DUET on a BIOS-based computer; on a system that supports EFI, you don't need to install DUET, so you can ignore the DUET information on that page.

  • Fantastic! That's actually the exact solution I was looking for! Thanks. In the end, I actually resorted to removing my CMOS battery for a while to restore the BIOS settings to optimized defaults... this allowed getting things out of "Ultra Fast Boot" mode for the time being. After that, because I've got a good backup solution in place, I decided to just reinstall the OS entirely and restore my data. After all was said and done, the Ultra Fast Boot setting was actually significantly more delayed with a proper UEFI install than it was previously... still a relatively fast boot time though. – JimNim Apr 1 '13 at 3:33
  • Link directs to a 404 error. – Alex Quilliam May 1 '17 at 21:49
  • Alex, this is another page that describes a similar procedure, but without the DUET emphasis. Also, Microsoft has released a tool for Windows 10 called MBR2GPT that does the same thing. I've never used the Microsoft tool, so I can't vouch for it personally, but if it works as advertised, it's probably simpler and safer to use. – Rod Smith May 2 '17 at 12:49
-1

Due to the high number of views, I wanted to ensure that my comment on the accepted answer doesn't go unnoticed for those not accustomed to StackExchange.

I actually used a work-around to get into the BIOS settings. 2 options that have worked well for this:

  1. Remove the CMOS battery from the motherboard (with power removed, and "flea power" drained)
  2. Use the "reset" jumper pins (while powered down / flea power drained), then removing the jumper and powering up

Both of these allowed me to get into the BIOS settings to disable "fast boot" or change any other needed settings. In the end, the most straightforward fix was to reinstall the operating system in UEFI mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.