My problem occurred literally over after my switch crashed. Resetting the switch brought everything back to normal except my Win 7 laptop lost connection to my network share. The Win 8 desktop can still access the share as normal, so I tested the following on my laptop:

  1. The server can be reached and pinged by IP
  2. ... and its netbios name. nbstat -a SERVER shows its name in the list, so netbios seems to work.
  3. The network browser does list some devices, but not all.
  4. clicking on any machine as well as my laptop itself does result in \\LAPTOP is not accessible.(... due to) permissions. Entering \\localhost results in Windows cannot access \localhost, check spelling
  5. Sharing any folder results in Your folder can't be shared. net share testShare=z:\Vids still adds testShare to the shared list, but still sharing isn't working.

I've tried

  • Both interfaces WLAN / LAN. LAN connected to the same switch as the Desktop.
  • disabling the firewall and AVG Antivirus
  • checked in the sharing center
    • Home network, LAN connection, Homegroup joined
    • Network discovery on, file and printer sharing on
  • Adapter Settings: QoS, File and Printer Sharing, IPv4, LL Discovery I/O and Responder
  • wmic service where name="SSDPSRV" get name, state
    wmic service where name="upnphost" get name, state
    wmic service where name="FDResPub" get name, state

    all return true.

Any ideas

  • where I can find detailed log messages why it's not working any more or
  • how to reset all windows sharing (smb) configuration
  • or any other suggestions?

Reinstalling the client for Microsoft networks and the File and Printer Sharing under the device brought me one error message further to: Error 0x800704cf the network location cannot be reached. I solved this by uninstall all (even hidden) network devices in the device manager and scan for new devices afterwards.


If you are having issues sharing a folder even though everything looks like it is setup correctly. Right click on the folder to share, go to properties. Click on Sharing tab, go down to Network path and click Share. Click on the drop tab and add Everyone to the group. Set your privileges and you should be good to go.


Had a similar intermittent issue affecting file servers and found it was caused by Commvault media agent being offline, and that stopping the Commvault services resolved it.


My server is a VM. I could ping the network server from the VM, but not access the shares. Firewall and Antivirus disabled on vm, made no difference. Got "Error 0x800704cf the network location cannot be reached".

Upgrading vmWare tools did it for me. :)


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.