My external hard drive can be read from but not written to. This is not the first time this problem has appeared. It started a few weeks ago. Sometimes it worked, sometimes not. If I unplug it, then plug it in again, then scan for errors it worked again. Then the problem started to appear more often and sometimes even scanning didn't work. At the end I could do nothing, so I was forced to copy the data and format the hard drive.

It worked for a few days, but now the problems start again. Same thing happened to an other hard drive (same model) of mine, but now that one seems to be OK.

What is this? A virus? What can cause a hard disc to not be writable? What can be the reason that this appears again? Is it possible that these are just bad hard drives (they are a cheap trekstor model)?

My feeling is that it is related to my specific computer. On my laptop, the same thing appears, but not that often.

closed as too localized by Ƭᴇcʜιᴇ007, Dave M, Scott, 3498DB, CharlieRB Apr 2 '13 at 0:48

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Does it appear read-only in a specific OS? Have you tried with any other? – Karan Mar 30 '13 at 17:31
  • 2
    Could you please provide some more details? Which error message do you get when you try to write to the hard disk? Which OS are you using? How is the hard disk formatted? – Pincopallino Mar 30 '13 at 17:33
  • It is formatted exFat. The operating system is windows 7 on both computers. At the moment I cant test it on any other OS. – Sebastian Starke Mar 30 '13 at 17:37
  • You can test it on another OS. Just download a live Linux CD and boot from it. No changes will be made to your computer and you can test if the drive is writeable there. – terdon Mar 30 '13 at 17:41
  • At the moment I can write most of the time, but sometimes the problem appears again. No I cant download anything the next few days. Im waiting for my new internet connection and my surfstick is empty (Dont know how to tell it in english), so it works with 60kbps. – Sebastian Starke Mar 30 '13 at 17:46

May be set write-protect in BIOS?

Enable USB Write:

Windows Registry Editor Version 5.00


Need restart.


enter image description here

enter image description hereenter image description here

Not the answer you're looking for? Browse other questions tagged or ask your own question.