Recently Picasa on Windows 7 has started not detecting photos that are imported from our camera (a Canon S3IS).

When I look in Picasa's folder monitoring options, the folders are there - marked "Scan Once". If I set them to "Scan Always", then they're scanned and the photos appear.

It used to "just work", I don't know what changed.


I don't see what the problem is. If you have the folder set to be scanned once, then that is what will happen. Picasa will scan it once, save the images in it and never scan it again.

What you want, as you yourself state in your question, is to scan always. That way, every time Picasa is opened, it will scan the folder for changes and import any new images it finds.

http://support.google.com/picasa/answer/11511?hl=en :

Select one of the following monitoring options on the right:

  • 'Scan Always': Picasa views all compatible image types in these folders, and it automatically adds new photos. Picasa actively scans this folder for changes.
  • 'Scan Once': Picasa accesses all compatible image types in these folders only once. It doesn't detect new photos added to folders with this setting.
  • 'Remove from Picasa': Picasa doesn't look in folders that are marked with this status.
|improve this answer|||||
  • Hmm, you're right, I can't have been thinking. I didn't think I changed the setting, but must have. – Peter Jul 1 '13 at 12:26

I have had picasa turn off the "scan always" randomly on my folders.

That seems to be getting better. Additionally, as I got above 30,000 pics, I find that scan always always does not mean immediate recognition. At times it can take 5 - 10 minutes before picasa recognizes there are new photos. Sometimes I need to restart picasa.

If you have a lot of photos, that could be a contributing factor. I'm asking a lot from this free program and do not consider it a bug so to speak.

|improve this answer|||||
  • So what if it's free? If there's a limitation on how many images it can handle then that should be clearly mentioned somewhere, else it's a bug. – Karan Apr 1 '13 at 10:22

My problem was I have a unique file system with manually created symlinks: c: - main windows installation v: - large RAID array with user data

I had symlinks of: %userprofile%\Photos\ pointing to v:\My Documents\Photos\

In the Picasa Folder Manager window the folder existing twice: One for the "Photos Library" and one for the v:\My Documents\Photos folder.

Making both items the same settings fixed it for me.

|improve this answer|||||

I solved an exactly similar problem by going into Picasa> Tools> File Types and thereby selecting all file types and clicking 'OK'.

And voila! It immediately started finding all those photos which I intended it to, but it didn't.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.