I recently upgraded from ubuntu 8.04 to 10.04 and now to 12.04 and have since broken my plesk install.

I have tried to repair plesk with

/opt/psa/admin/sbin/autoinstaller --select-release-current --upgrade-installed-components

This however returns ERROR: The product with ID plesk is not installed on the server

So I tried to work this out with: cat /opt/psa/version

10.4.4 Ubuntu 8.04 1013111102.18

Then i tried /opt/psa/admin/sbin/autoinstaller --show-all-releases

release_id  (description) (branch) ---
plesk PLESK_11_5_21 (Parallels Plesk Panel 11.5.21 (testing)) (testing)
plesk PLESK_11_0_9 (Parallels Plesk Panel 11.0.9 (stable)) (stable)
plesk PLESK_10_4_4 (Parallels Plesk Panel 10.4.4 (stable)) (stable)
plesk PLESK_10_3_1 (Parallels Plesk Panel 10.3.1) (stable)
plesk PLESK_10_3_0 (Parallels Plesk Panel 10.3.0) (stable)
plesk PLESK_10_2_0 (Parallels Plesk Panel 10.2.0) (stable)
plesk PLESK_10_1_1 (Parallels Plesk Panel 10.1.1) (stable)
plesk PLESK_10_1_0 (Parallels Plesk Panel 10.1.0) (stable)
plesk PLESK_10_0_1 (Parallels Plesk Panel 10.0.1) (stable)
plesk PLESK_10_0_0 (Parallels Plesk Panel 10.0.0) (stable)
plesk PLESK_9_5_4 (Parallels Plesk Panel 9.5.4) (stable)
plesk PLESK_9_5_3 (Parallels Plesk Panel 9.5.3) (stable)
plesk PLESK_9_5_2 (Parallels Plesk Panel 9.5.2) (stable)
plesk PLESK_9_5_1 (Parallels Plesk Panel 9.5.1) (stable)
plesk PLESK_9_5_0 (Parallels Plesk Panel 9.5.0) (stable)
plesk PLESK_9_3_0 (Parallels Plesk Panel 9.3.0) (stable)
plesk PLESK_9_2_3 (Parallels Plesk Panel 9.2.3) (stable)
plesk PLESK_9_2_2 (Parallels Plesk Panel 9.2.2) (stable)
plesk PLESK_9_2_1 (Parallels Plesk Panel 9.2.1) (stable)
plesk PLESK_9_2_0 (Parallels Plesk Panel 9.2.0) (stable)
plesk PLESK_9_0_1 (Parallels Plesk Panel 9.0.1) (stable)
plesk PLESK_9_0_0 (Parallels Plesk Panel 9.0.0) (stable)
plesk PLESK_8_6_0 (Plesk 8.6.0) (stable)
plesk PLESK_8_4_1 (Plesk 8.4.1) (stable)
plesk PLESK_8_4_0 (Plesk 8.4.0) (stable)
plesk PLESK_8_3_0 (Plesk 8.3.0) (stable)
plesk PLESK_8_2_1 (Plesk 8.2.1) (stable)
plesk PLESK_8_2_0 (Plesk 8.2.0) (stable)
plesk PLESK_8_1_1 (Plesk 8.1.1) (stable)
plesk PLESK_8_1_0 (Plesk 8.1.0) (stable)
plesk PLESK_8_0_1 (Plesk 8.0.1) (stable)
plesk PLESK_8_0_0 (Plesk 8.0.0) (stable)
plesk PLESK_7_5_4 (Plesk 7.5.4) (stable)
plesk PLESK_7_1_7 (Plesk 7.1.7) (stable)
ppsmbe PPSMBE_10_2_0 (Parallels Small Business Panel 10.2.0) (stable)
ppsmbe PPSMBE_10_1_0 (Parallels Small Business Panel 10.1.0) (stable)
ppsmbe PPSMBE_10_0_0 (Parallels Small Business Panel 10.0.0) (stable)
sitebuilder SB_4_5_0 (Sitebuilder 4.5.0) (stable)
sso SSO_2_0 (SSO 2.0) (stable)
sso SSO_2_1 (SSO 2.1) (stable)

In short, my plesk is broken, it won't start.

root@sub:~# /etc/init.d/psa start
Starting psa...                                                       failed
Starting xinetd service...                                            done
Starting bind9 service...                                             done
Starting mysql service...                                             done
Starting postgresql service...                                        done
Starting psa-spamassassin service...                                  not installed
Plesk: Starting Mail Server...                                        not installed
/etc/init.d/psa: line 269: /opt/psa/admin/sbin/websrvmng: No such file or directory
Starting psa...                                                       failed

Hence me trying to repair the install of plesk.

1 Answer 1


Can you check availability of psa package in your system? Or better - availability of all psa* packages?

This ERROR: The product with ID plesk is not installed on the server (1) and this Starting psa... failed (2) messages make me think that during OS upgrade some of your Plesk packages were dropped. Probably because they might require some of your older OS's packages by dependencies. Remember, Plesk distribution is OS specific, so OS upgrade cannot be recommended way.

Bad news is that now you will have to scan logs from all dropped packages and try to bring them back (which might be not that easy). Good news is that your data are probably ok, so if you make new Plesk server and use Plesk Migration and Transfer Manager (be sure you choose to install it), you probably can transfer all data to newer server without loss.


I noticed you were trying to update Plesk. Actually you could try re-installing it, the management database and content should be preserved. You could do that by

/opt/psa/admin/sbin/autoinstaller --select-product-id=plesk --select-release-current --upgrade-installed-components

if that fails too, you can backup psa database and sites and then do full re-install

/opt/psa/admin/sbin/autoinstaller --all-versions

After that database and content will need to be restored manually.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .