I am trying to use Bluestacks for running Android application on my Linux Fedora using Wine.

I tried wine BlueStacks-SplitInstaller_native.exe from terminal. It gave me Install Mono for Windows to run .NET 2.0 ... error, so i downloaded Mono For Windows from here.

I installed the complete package [checked all boxes including GTK etc] it using

wine mono-2.10.9-gtksharp-2.12.11-win32-0.exe After the installation is done. After a while it just seemed to stop executing commands. However it did not return the prompt on terminal even after waiting for a long time,so i did Ctrl-C to get back the prompt. This showed some fixeme for the console.

Following this by,

wine BlueStacks-SplitInstaller_native.exe The bluestacks installer comes up and immediately gives the error dialog stating

Unhandled exception: page fault on read access to 0x7de321a8 in 32-bit code (0x100035cf).
Register dump:
 CS:0073 SS:007b DS:007b ES:007b FS:0033 GS:003b
 EIP:100035cf ESP:0033f57c EBP:0033f5a0 EFLAGS:00010246(  R- --  I  Z- -P- )
 EAX:0012bd98 EBX:0033fa54 ECX:7de32160 EDX:0033f594
 ESI:00000643 EDI:0033f84c
Stack dump:
0x0033f57c:  0012bd98 0033f594 0033f84c 00000643
0x0033f58c:  0033fa54 00000136 00000000 00000000
0x0033f59c:  84ac8254 0033f64c 10005604 00000002
0x0033f5ac:  0012bd98 1001854a 0033f84c 0033fa54
0x0033f5bc:  0033f5d0 002206ec 00000000 00220706
0x0033f5cc:  00220706 7bc3d409 00000643 0012bd98

and lot other details.

The installer meanwhile continues upto 98% installation and hangs.

What step did i do wrong?

Note: I don't want a VM for this purpose (I am not going to do anything on Windows except use Whatsapp). Any other alternatives are welcome. I have tried with Youwave too, but with little success.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.