When installing Notepad++ on Windows 7 64-bit, I receive this error:

Error opening file for writing:

C:\Program Files (x86)\Notepad++\langs.model.xml

Click Abort to stop the installation,
Retry to try again, or
Ignore to skip this file.

Of course, if I click Ignore, it will just error out on the next file and the next file (if I click ignore, yet again), and so on.

After searching Google, I found a lot of people who received a similar error when trying to load it (after the install), but no one who experienced this problem on an install. Is there a workaround to this?

  • Does the file langs.model.xml already exist? From a previous installation? It might help to repeat the installation as Administrator and/or to remove the old installation beforehand. Apr 1, 2013 at 15:09
  • It does not exist, nor does any previous installation exist. I tried installing as the Admin, yet it still generates this error. Even if I ignore this error, it will just error out on the next file. Apr 1, 2013 at 15:14
  • There is a spelling error in Notepadd++. It should be Notepad++ with a single d. Apr 1, 2013 at 15:16
  • Thanks @AxelKemper; unfortunately, that was my own error. Apr 1, 2013 at 15:18
  • 1
    Try to install Minimalist instead of custom installation..
    – user305139
    Mar 5, 2014 at 5:11

12 Answers 12


Download the ZIP package from the Notepad++ website. Unzip it, and then copy the langs.model.xml file from the package into C:\Program Files (x86)\Notepad++.

The application doesn't necessarily need to be installed, either. You can always just unzip the package to your preferred location and then launch the application directly from that folder. Should work just as well.

In any case, I believe you answer lies in downloading the .ZIP version of Notepad++, not the Windows Installer.

  • Thanks @dtdlurch; awesome hack - worked perfectly! (I would upvote it, but lack the rep - nonetheless, thanks). Apr 1, 2013 at 15:28

I encountered the same problem when tried to install the latest version, npp.6.3.2.Installer.exe.

One solution is: right click and Run as Administrator. It works properly then.

  • This should be the accepted answer as it addresses the main problem. The windows installer is just fine and needs no hacks.
    – tryurbest
    Jul 7, 2014 at 21:13
  • After I did this, Notepad++ would only run as admin afterwards. I had to go to the Notepad++ executable and uncheck "Run this program as administrator" from the compatibility tab to get it to launch as my regular user account.
    – indiv
    Oct 12, 2015 at 16:36

I just experienced the same issue with the new v6.3.2. Uninstalling, rebooting, and trying the previous version resulted in the same failure.

I ended up starting an "Administrator" command prompt and running the installer from there. It worked.
> pushd %USERPROFILE%\Downloads
> npp.6.3.2.Installer.exe

I think the Windows installer is failing to launch the UAC prompt to request admin rights when double-clicked. The command prompt trick works around this.


I had the same problem with the installer, and running as Administrator didn't fix it. It turned out that a different user account on the same computer had the app open, so the files were locked. The solution was to open Task Manager and kill the other Notepad++ process.


I had the same error, it was a permission issue. I opened the entire folder (.\Notepad++) up to EVERYONE full access as well as edited the special permissions in Advanced settings and chose to

"Replace all child object permission entries with inheritable permission entries from this object"

for the installation and it worked.


It looks like the NPP installer requires admin rights. To grant the permission:

  1. Right Click the installer npp.x.x.Installer.exe and
  2. Chose to Run as Administrator
  3. The installer will get the authorization it needs and complete in seconds.

On a PC with UAC enabled, the oft-mentioned answer of "Run the installer as Administrator" is not descriptive enough, because if you install it in the default location Programs (x86) then every time you use the program as a non-Administrator you will get the annoying UAC pop-up "This program wants to make changes to your computer..." very annoying. The other answer "don't install it, just unzip it in My Documents and run it" is also insufficient because then I found that you cannot set Notepad++ as the default application for specific file types (maybe because it was not officially installed?) --- So my solution that takes care of both issues was to run the installer as Administrator, but override the install location to my own personal My Documents\Programs\Notepad++ folder. Now both issues are solved.


I tried the above solutions, but still got the error during install. My working solution was to open Task Manager and end all notepad++ processes (I had 3 of them running for some reason), and then running installer as an administrator.


TL;DR: Try to rename folder. If it fails, someone is holding it.

I just had a small variation of @Rey Muradaz`s answer. For me, it was GUP.exe which was hung.

How did I find it? I tryed to rename the folder where Notepad++ was installed. Windows refused, stating, that someone has some files open. I did digging around in Task manager (no-one did), so I went to "Resource Monitor" and in CPU section i searched for folders name and there it appeared - GUP.exe was still running. So I killed it and updater started working. :-)

  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Mar 25 at 9:47

I too had the same error. I got it resolved by restarting the PC after i was given Admin rights. It seems the windows OS has to reboot itself to take into changes in the access rights.

  • 1
    This duplicates another answer and adds no new content. Please don't post an answer unless you actually have something new to contribute.
    – DavidPostill
    Apr 7, 2016 at 13:38

To resolve this problem you must uninstall NotePad++ by the Control Panel.

Then remove all files from the C:\Program Files\Notepad++ folder and do a fresh install.

  • This doesn't fix the problem. The correct answer is to install as administrator.
    – DavidPostill
    Aug 26, 2016 at 7:26
  • Fixed it for me. More specifically, uninstall notepad++ then restart the explorer.exe service from taskmgr, delete the folder, and finally run the x64 installer as administrator.
    – Cory Silva
    Jan 17, 2017 at 5:49

I encountered the same problem on Windows 7 64 Bit, when installing Notepad++ version 6.5.5.

Running the installer as Administrator solved the error in the installation.

  • 1
    Not a bad answer -- just a repeat of an earlier one.
    – Martin F
    Mar 12, 2015 at 0:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.