0

I'm desperately trying to make Gnome Shell work with multiple monitors. I'm on Gentoo. I'm using the proprietary ATI drivers.

I did the configuration with the aticonfig tool.

I tried using Xinemara, but then Gnome Shell starts in Fallback mode only.

I tried without it. In this configuration, I can see both screens, but they seems separated. I cannot move Windows from the first one the second and the window manager of the second seems weird, I cannot close windows on them. When I put the mouse on the second screen, a cross appears as the cursor.

What is the correct way to configure dual monitor for Gnome Shell with ATI drivers ?

Thanks

1

Do you have the ATI configuration app or the Catalyst Control Center?

Either way it sounds like when you had two screens up you were almost there but it was set as two separate X sessions, one per monitor where you would have two keyboards, two mice and two users on one machine.

The clone setting will display same image on both monitors – you will be looking for the Extend Desktop option (might be named slightly different). Let's see what happens.

  • I have the ati configuration in command line. I have not the catalyst control center. I came back without xinemara and a weird thing is that in the "Displays" Configuration screen of Gnome, only one screen is displayed, so you may be right about the two X sessions. But I do not see how to extend display with aticonfig. – Baptiste Wicht Apr 3 '13 at 8:21
0

Finally, I installed the Catalyst Control Center, configured my dual monitors there and rebooted and it worked directly.

  • Excellent!! enjoy dual monitors! – user213584 Apr 8 '13 at 5:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.