Recently, after a power supply crash problem, my linux machine (Centos 5.5 X64) did not boot neither gnome nor shell. On gnome startup it shows this error:

/etc/X11/prefdm: line 16: :/etc/sysconfig/desktop: cannot execute binary file /usr/bin/rhgb-client: error while loading shared libraries: /usr/lib64/libpopt.so.0 invalid ELF header

I tried rescue disk, but it couldnt recognize my OS! There is a chance that this problem is caused by hard disk problem. Cause of when I tried to boot OS from runlevel 3, some error regarding to Raid disk and hard drive appeared and disappeared fast which I could not read all of them, after these errors disappeared a Hello World page shows up that nothing can be done. I am using hardware Raid on this machine (intel storage matrix).

Could somebody please help me for booting this machine? I have some important services running on this machine which I need it fast.

Best Regards.

1 Answer 1


Try reinstalling the library:

yum whatprovides libpopt.so.0
yum install <best result from above command>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.