7

I recently got a new pair of Sony MDR-1RBT Bluetooth headphones. On my iPhone 4, they sound fantastic. But when I try to use them on my Windows PC or 2010 Macbook Pro, the sound quality drops substantially. I'm pretty sure they're still using the A2DP profile, but they sound like FM radio, or like an MP3 encoded at 64kbps. (I don't think they're pairing in headset mode.) On OSX, many people have recommended changing the "bitpool" setting, but this didn't help me much. There's also maybe a second of lag, so gaming is out of the question.

I remember having these sorts of problem with Bluetooth 5 years ago, and I'm shocked that they still haven't been fixed. Am I missing something? Why does my dinkly little iPhone play wireless audio so well while my powerhouse computers do not? Is this adaptor dependent? Can I just force Bluetooth to send the highest quality stream possible at the expense of latency?

4

I bought a USB based Bluetooth 4.0 device: Plugable USB-BT4LE

I use Windows 7 Enterprise.

I also had your problem, only with a generic set of Bluetooth headphones. This set of headphones does not have a microphone. The Windows Bluetooth utility decided that it had one, anyway.

It became apparent that either the Broadcom drivers, or the Windows Bluetooth management subsystem were forcing the headphones into some sort of fallback, low-quality mode.

To fix it here is what I had to do:

  1. Open 'Recording Devices' control panel applet
  2. Locate the microphone device associated with your Bluetooth
  3. Right click on the item and choose 'Disable' from the list
  • Thank you for the reply! As it so happens, my problem wasn't related to the low-quality microphone mode. (I could get it into that mode manually, and it sounded far worse than what I was experiencing.) My issue definitely had to do with SBC encoding quality, which could be fixed on my Mac. – Archagon Apr 23 '13 at 5:44
  • I am on OSX 10.9 and having the headset microphone enabled was my issue as well. As soon as I disabled it worked fine. – RobertS Oct 29 '13 at 19:54
  • Disabling the mic fixed it for me on Windows 7 as well. – Nathan Donnellan Feb 26 '15 at 16:27
1

I managed to fix the audio on my 2010 Macbook after fiddling with the bitpool settings a little more. For future reference, here's what you need to do:

  1. Go here and download the Hardware IO Tools for Xcode. (You'll need a free developer account for this.)
  2. Open Bluetooth Explorer.
  3. Go to Utilities->Special Options.
  4. Slide the "Minimum bitpool" slider up to 45+. (Mine is set to 50.)
  5. Disable and re-enable Bluetooth.

For the record, my headphones work perfectly fine with my 2011 Macbook at work, so hopefully this won't be an issue with Apple's newer laptops.

On my Windows PC, I'm guessing the issue is my crappy Bluetooth adapter combined with generic drivers.

  • Update: in the latest version, this is now under Tools->Audio Options. – Archagon Feb 12 '14 at 7:49
1

I had this problem too in my MacBook Pro. You just need to run the following command in Terminal:

defaults write com.apple.BluetoothAudioAgent "Apple Bitpool Min (editable)" 60

Seems that by default OS X sets a terrible quality of sound in A2DP.

Source: http://danwarne.com/fix-bluetooth-a2dp-audio-quality-mac-os/

1

My latest theory is that iPhones do a better job of negotiating higher bitpools (higher bit rate, thus less data compression) on sbc than many other devices, including all of the android devices I have owned. That is why sbc devices sound better driven by an iPhone. You can hear how good sbc with an iPhone can sound here: https://www.youtube.com/watch?v=d7j-Vwj-JyQ

I am trying to track down more evidence and data, and will update if I learn anything new or definitive.

0

In Ubuntu try:

hcitool scan  
gconftool -t string -s /system/gstreamer/0.10/default/musicaudiosink "sbcenc ! a2dpsink device=XX:XX:XX:XX:XX:XX"

Where xx:xx:xx:xx:xx:xx is the mac address found from hcitool scan. Found here

In windows, try updating your bluetooth stack.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.