Ok, here's the details guys:

I have 2 users in one room Hooked up to an Epson Printer. The printer is relatively old, old enough that it has to be plugged into the Old Printer port in a relay box and that box is connected to the network, sending and receiving the printers commands.

One user can use the printer without issue. There is absolutely no problem with his computer. However, across the room from him is another user who, until recently, was able to print to this printer as well.

Now, when she tries to print to this printer, it comes up as invalid on the program she is printing from. I tried to print a test page, and it just held the job in the queue without printing it, to the point of having to delete it so I could change settings. I have reloaded the driver for the printer via the wizard twice, after deleting the printer each time. Both times, it still had the yellow triangle over the printer icon. I tried the MS Auto Troubleshooter, twice, and both times it told me to reinstall the printer, which I did, only to have the same result.

I also tried this from the dedicated admin account for the network, and it still had the same result. I have tried printing directly to the printer, and spooling the print job, same result. I even connected to the printer via its IP address, and same result.

Usually, when I go so far as to reinstall the printer on a system, that does the trick. I have never had a printer go this crazy.

Also, this may be related, but several other older printers around the network are doing the same thing. I am trying as hard as possible to not have to replace these printers, because at times they work. And, to replace them all would be a great cost to the company, which I cannot incur.

Any ideas to help me out? The initial user who cannot print is responsible for 90% of our invoices, and if she cant print she has to email the invoices across the office and wait for the other employee there to have the time to print it. This is a vital function of this particular office, so any and all help or suggestions will be appreciated. Thanks.

  • What OS is each user running? What is the model # of this printer, have you tried downloading the latest drivers from the vendor website? Do they have other printers they are able to successfully print to? I assume this printer has an IP assigned to it since it is plugged into this relay box that connects to the network? – j_bombay Apr 4 '13 at 18:30
  • Both users are running Win7 Pro. The Printer is an Epson LQ-590. I am going to try the latest drivers, but as I had done the windows update to pull the newest drivers, I am not sure that it will work. The Printer does have its own IP, as I previously indicated. – Aaron Hardy Apr 4 '13 at 18:43
  • 1
    With the problem user's printer settings, after you remove the printer how about removing the tcp/ip IP address (and any that also have the 192.168.xx.xx_1) that match the same IP, so that way when you add the printer again, you have to add the tcp/ip port, instead of selecting one that is already created? – j_bombay Apr 4 '13 at 20:13
  • I'll try that and see what comes up, will report results. – Aaron Hardy Apr 4 '13 at 20:16
  • @j_bombay - I tried it, and it worked. Thank you. – Aaron Hardy Apr 4 '13 at 20:28

My initial suspicion is that the relay box has a problem for some odd reason, can you post what the relay box is? Also, have you tried restarting the relay box?

Next question: The LQ-590 as shown on Epson's site has a USB interface in addition to the parallel interface. Have you tried plugging it directly into one of the user's computers and then having that computer share the printer over the local network?

It's not an optimal setup because the computer that does the sharing has to be on for the other person to print, but by eliminating the network relay box, you eliminate one point where things can go quite drastically wrong.

Updated: Have you compared firewall settings on the two computers (affected vs. non-affected)? I'm not at all sure how the remote print device works, but it's not inconceivable that something triggered a firewall change, and that led to printer disfunction.

  • Well, see, the thing here is that one person is printing just fine and the other isnt. I dont think the issue is with the relay box, since its working fine for the other person in the same room without fault. Also, i tried to download the drivers, but Vista 64-bit is the last version they put out, there is not a Win7 option for the driver. I know the Vista 64 should be compatible, just making an observation. – Aaron Hardy Apr 4 '13 at 19:54
  • @AaronHardy - I'm just thinking that the relay box adding a variable into the mix that may be the root of the issue. Routing around the relay box reduces the number of variables in play, and therefore the likelyhood of success. – Michael Kohne Apr 4 '13 at 20:07
  • @AaronHardy - I just added 'check the firewall' config to my answer. Might be worth your time to compare the two. – Michael Kohne Apr 4 '13 at 20:11
  • Id like to eliminate the relay box, but being that it is the only thing keeping them able to print their invoices right now I have to leave it in place until I can fix the issue. Once the issue is fixed, tehn I can schedule some downtime for them to reconfigure the setup. – Aaron Hardy Apr 4 '13 at 20:13
  • There are layers of options in the winders printer settings, if nobody messed with them, I cant see how it could be them. but it certannly adds to the complications, especially if you do mess with them :-) like RAW or LPR and the port options, and its endless. in XP there was even more odd options. Right click printer, Printer properties, that whole array of tabs, then in ports Configure the port itself it is on, a few options in there. – Psycogeek Apr 4 '13 at 20:20

With the problem user's printer settings, after you remove the printer how about removing the tcp/ip IP address (and any that also have the 192.168.xx.xx_1) that match the same IP, so that way when you add the printer again, you have to add the tcp/ip port, instead of selecting one that is already created.


You say you "deleted" the printer twice. However, that by itself does not delete the driver files. Here's what you need to do.

First delete the printer. Then click on any other printer and a link to print Server Properties will appear. Click on that, and then on the Drivers tab. Remove any instances of the printer from the list. Click OK.

Before reinstalling the driver I would also remove the TCP/IP port. Click on any other printer, then on Printer Properties. Click on the Ports tab, right-click the TCP/IP port and delete it.


I have run into issues like this before and found that the print spooler service to be disabled. Once it was restarted, and the settings changed to Automatic everything worked fine. I hope this helps.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.