I am trying to use a Java applet (any Java Applet), but I always get a messages saying "Error. Click for details".

When I do so, the pop-up says:

Application Error



When I click the "Details" button, all I see is the following:

Java Plug-in 
Using JRE version 1.7.0_07-b10 
Java HotSpot(TM) Client VM 
User home directory = C:\Users\Beth
c:   clear console window

f:   finalize objects on finalization queue

g:   garbage collect

h:   display this help message

l:   dump classloader list

m:   print memory usage

o:   trigger logging

q:   hide console

r:   reload policy configuration

s:   dump system and deployment properties

t:   dump thread list

v:   dump thread stack

x:   clear classloader cache

0-5: set trace level to <n>

I am running Windows 7 Professional, and am up to date on patches.

The problem occurs in Google Chrome, Mozilla Firefox and Internet Explorer, regardless of what Java Applet I am running.

The error I quoted above came from here: http://java.com/en/download/installed.jsp?detect=jre

but it happens on every java applet website.

I have attempted the following to rectify the issue:

Uninstall and reinstall Java

Uninstall Java, reboot, install Java

Uninstall Java, delete all registry entries, reboot, install Java

Tried All versions of Java JRE and JDK.

In addition, I have run Malware and Virus scans, none of which have shown anything of relevance.

  • You say "every java applet website", have you tried any local java applications? Have you tried uninstall and reinstalling Chrome or Firefox? Do you have any "Click to play" settings or extensions affecting Java? – Colin Pickard Apr 4 '13 at 20:35
  • I tried installing runescape locally, would that count? It didn't work, gave me the rs2applet.class but same error. I've tried uninstalling and re-installing chrome and firefox, I even went as far as installing IE to try it. Right now I am just using Google Chrome, all the other browsers have been uninstalled. Does chrome have a click to play setting? Other than that, I don't think any other settings or extentions are currently interfering with it. – Devon ShowTime Williams Apr 4 '13 at 20:36
  • Hang on a minute; did you already post the exact same question? or copy-paste? This looks identical: superuser.com/questions/469707/… – Colin Pickard Apr 4 '13 at 20:41
  • I pasted this on StackOverflow, a guy that was there told me to try here, since it wasn't coding. The super user question isn't me, but it looks like he has the same issue, although I don't have the program Elluminate installed as he did, I have no idea what is causing my problem. :( – Devon ShowTime Williams Apr 4 '13 at 20:42
  • 1
    Couple of things you could try: use JavaRa to completely remove Java then reinstall. Or try turning off any third party firewalls temporarily. – Colin Pickard Apr 4 '13 at 20:48

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.