I have recently bought an Toshiba Satellite P855-32X laptop.

Firs thing after I did launch this laptop is ofcourse update all drivers to the newest ones. Configure everything I needed and it works like a charm.

I can play all the newest games without problems, but when running a game called "Dark Reign 2" [DirectX 7] it runs at 25 FPS / ~20 FPS max (no matter if settings are lowest @ 640x480 or highest @ 1366x768), while on my older laptop with an i3-370M and a AMD Radeon HD Mobility 5740 [512mb gddr3 vram] it runs at 120 fps. (however I always limit it in-game to 60)

My laptop has an RMB option on applications which allows you to specify with which GPU to run an application with: enter image description here

But after launchin DXdiag with this option, or the second, I always get this screen: enter image description here

I tried looking into the NVidia CPL but it doesn't have as much options.. as it should?:

enter image description here

I also made sure my "default GPU" is set to the NVidia GPU. Yet still the problem persists.

I tried disabling my Intel Integrated HD Graphics:

enter image description here

But when I tried to run the game it gave me an error the there is no Harware Acceleration support (for a game from 1999 hehe)

So I looked it up in DXDiag:

enter image description here

And what suprises me here is that there is absolutely no GPU/manufaturer name and the default windows drivers are used..

All my drivers are up to date, all VC++ redistributables, .net frameworks, windows updates, dependencies and DirectX End User Runtime (DX9) are all up to date and installed.

I really don't know what the problem is and I really hate it that I can't play an old game at more than 25 fps yet all the new games (2005+) on a more playable framerate.. yet, on an older laptop the game runs like a charm.

What is going on and how can I fix this? I really don't understand this.

I suspect my Geforce is "connected" to the motherboard with the Intel Chipset -in between- ? Is there any way to circumvent this if this is true?

Edit: I forgot to mention I did run the game with "use integrated GPU" and the results were the same. (game running on 25 fps max)

  • Do you have Windows 8 on your older laptop or Windows 7? Can you please try running the game with compatibility mode set to a lower Windows Version, perhaps playing with the other setting you have there? – user127350 Apr 22 '13 at 19:46
  • 1
    Under the "manage 3d settings" tab in the nvidia control panel, you should be able to navigate to your game's .exe and specify which GPU to use from there. Sometimes the context menu entry doesn't work properly if the shortcut triggers some kind of launcher instead of the game itself. Finally, you can use the Optimus Test Viewer tool to determine with certainty which GPU is being used for each application. – Fopedush Apr 22 '13 at 20:01
  • @Fopedush At last, some useful info. :) – user127350 Apr 22 '13 at 20:05
  • I'm certain there is no launcher, the application is open source.. – user144773 Apr 22 '13 at 20:18
  • 1
    One more thought occurs: Your screenshot of the nvidia control panel shows one hardware output connected directly to the nvidia frambuffer (it appears to be a d-sub). You might try connecting a display to that output (verify in the nv. control panel that it shows up connected to the nvidia card and not the Intel one), then run the game on that display. Doing this will remove the IGP framebuffer from the equation completely, and may give you a hint as to the source of the trouble. – Fopedush Apr 22 '13 at 21:05

I authored a question on this subject a few years ago, so I might as well chime in with what I know.

Your laptop uses a technology called Nvidia Optimus to render video output from two GPUs (the integrated Intel graphics processor, [IGP], and the more powerful Nvidia graphics card [DGPU]). This is accomplished by connecting the laptop's screen to the framebuffer of the IGP only, and allowing the DGPU to write pages of memory directly into that framebuffer. In this way, both cards can render output to the same screen, even simultaneously. When an application calls for DGPU rendering, the DGPU writes output to the portion of the screen that the application occupies. In the case of a full screen application such as a game, the DGPU will write to the entire framebuffer of the IGP. A much more detailed description of this process is available in the Nvidia Optimus whitepaper.

When running a graphics-heavy application such as a game on an optimus-enabled machine and experiencing poor performance, it is logical to start by ensuring that the application is making use of the DGPU rather than the IGP. You can do this via the context menu entry you showed, or, somewhat more reliably, through the NVidia control panel. Simply select "Manage 3D settings" from the pane on the left, select your application, then set the "Preferred graphics processor" to the Nvidia chipset.

You can ensure that the application is running on the Nvidia GPU by using the Optimus Test Viewer. This tool will indicate whether or not the DGPU is enabled, and can list which processes are making use of it.

A final workaround for optimus-related issues exists in the hardware outputs of the video card. The Nvidia control panel, as in your screenshot, can display which physical outputs are connected to which monitors. From your screenshot, it appears that the Nvidia GPU has one physical output - You can try plugging an external monitor into this output and confirming that it appears connected correctly in the Nvidia control panel. If so, your montior is now hooked directly to the framebuffer of the DGPU, meaning that optimus is not in use, and all rendering on that monitor will take place on the DGPU.

Based on the discussion in the comments on your question, you have done the following:

  1. Forced use of the DGPU for your game through the Nvidia control panel
  2. Verified through use of the Optimus Test Viewer that the game is using the DGPU
  3. Connected a monitor to the DGPU's hardware output and run the game on that monitor

And despite all of this, the game still runs very poorly. I can only conclude from this information that the problem is not optimus related, but is some other problem - possibly a compatibility issue arisen from such an old game, or from some property of the configuration of your new laptop. You have mentioned that this game is open-source - if there is an active development community, they may be the next best bet for finding a resolution to this problem.

  • I will wait with the +200 a few days, if no onebeats you you will get it :P and I'm trying to update the source now.. and for community, well, kinda - not existent. – user144773 Apr 23 '13 at 22:03
  • Very nicely written, but the conclusion is not new: this one game has a problem running on this computer's hardware, probably because of its age. – harrymc Apr 24 '13 at 7:51
  • what I noticed: when running Dark Reign 2 in WINDOWED MODE (can be changed in game options, yay) it DOES achieve 350 FPS (uncapped, no vsync in windowed mode) on my laptop...so what the... f.... is going on? ;o this is driving me crazy ;f – user144773 May 22 '13 at 21:34

The game Dark Reign 2 dates from June 30, 2000.
As such, it does not use the latest GPU Streaming SIMD Extensions.

This might explain why it cannot use a modern GPU such as yours.

  • What you're saying is that if I know how to add two numbers, and I learn the multiplication operation, I can't do an addition anymore. – user127350 Apr 23 '13 at 8:26
  • You are a bit behind your time - it's now 15 years that graphics is not only about add and subtract. Modern GPUs are computers in their own right, with a very parallel architecture driven by new CPU instructions (read my link). If the game doesn't know how to issue these instructions because they were added by Intel after the game came out, then it will not be able to drive the GPU at full speed. (And you are too trigger-happy on your down-voting.) – harrymc Apr 23 '13 at 10:08
  • I said addition and subtraction, just for the sake of keeping it simple (do you know what KISS mean?). He said the game worked perfectly on his AMD Radeon HD Mobility 5740, which is a modern GPU. You are so fixed on your idea that you can't see the whole picture here. Both computers are almost the same age, and on one everything works perfectly, on the other it doesn't. Stop speaking from your theoretical knowledge about technologies invented more than a decade ago. I'm not too trigger-happy on down-voting, but I don't like people speaking nonsense. – user127350 Apr 23 '13 at 10:31
  • @Radoo: Then explain "I can play all the newest games without problems, but when running a game called Dark Reign 2". And also: "on my older laptop ... it runs at 120 fps". Evidently, this game is not optimized for his more modern GPU. I don't care if this is a bug in it the game graphics or if it doesn't use the right graphical instructions or that the older computer does not support the latest drivers. For me this is a time-oriented problem. – harrymc Apr 23 '13 at 11:04
  • hm but that still doesn't make that much sense, my older laptop is from 2010... this one from 2013,is it really that much difference? – user144773 Apr 23 '13 at 13:37

Your problem is simply that you updates the graphics drivers, try uninstalling both nvidia and intel vga drivers and put the original ones given by the laptops brand.

After this is done, select the game u wanna play and right click the app then select "Run with graphics processor -- Select NVIDIA"

thats it your all good to go and keep in mind to never update the nvidia or intel driver again or your FPS will go below what you want.

Source: Had the same poroblem and fixed it this way

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy