I've gone through some of the similar questions asked, but none seem to quite solve my problem.

I have a VirtualBox 4.2 install on Ubuntu 12.04 (x64) as host, with Ubuntu 12.04 Server (x64) as guest. I misjudged initial storage needs and wish to resize my .vdi disk.

I tried the following:

vboxmanage modifyhd file.vdi -31744

To resize my vdi disk to 31GB, and it gave me a successful completion message. Virtualbox notes the file as having a virtual size of 31GB, actual size 4.23.

I've tried using both GParted live and Ubuntu LiveCD with GParted, but the result is the same: the new space simple does not appear. GParted can still only find one disk /dev/sda, which is the same size before I tried resizing it with vboxmanage. Obviously, this means I cannot repartition.

Has anyone run into this issue before? I would greatly appreciate some insight.

PS. The filesystem is ext4.

Edit: I just noticed that my actual .vdi file has not grown in size. I would have thought that it would. Might be worth mentioning.


Create a second bigger disk, use gparted to copy the contents of the old disk to the new one, then delete the old one.

  • I was trying to avoid having to clone over the disk if at all possible, unfortunately. – user991710 Apr 5 '13 at 0:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.