3

My guest machine screen is very lagging, open a window then minimize it will remain the unresolved drawing on the guest OS's desktop.

I try to increase the display adapter memory size but it doesn't help.

How can I get the display smooth?

3
  • 1
    If your Guest OS supports it and you haven't already done it, consider installing the Virtualbox Guest Additions on your VM. In certain cases the Guest Additions can greatly improve smoothness and performance with your VMs.
    – Mono
    Apr 8 '13 at 15:58
  • It's great! Please move your comment into an answer so as to get accepted. Please put the link virtualbox.org/manual/ch04.html#additions-windows to jump to the correct specific section for my question. Thanks!
    – Nam G VU
    Apr 8 '13 at 20:49
  • I've tried to install the Virtual Guest Addition but after that screen response is very slow... It's not getting any better Alex
    – Nam G VU
    Apr 9 '13 at 17:50
1

I figure it out myself. By turning of the 2D and/or 3D accelebration as snapshot below. My screen goes smooth now.

enter image description here

1

Virtual Box suggests you install their "Virtual Box Guest Additions" to improve VM performance. It improves the general user experience with things like mouse integration that will allow users to more easily switch between their Guest OSs and their host, and generallytypically it will improve video performance by a significant amount with their custom video drivers.

3
  • I've tried to install the Virtual Guest Addition but after that screen response is very slow... It's not getting any better Alex
    – Nam G VU
    Apr 9 '13 at 17:51
  • Do you still have hardware acceleration enabled in your prefences? If you left it enabled, try disabling it and see if it improves. Also, what display adapter are you using in your host OS? Running virtual machines can be quite resources intensive, and I'm not sure as to how well they are able to perform on integrated adapters.
    – Mono
    Apr 9 '13 at 18:06
  • Disabling hardware acceleration will stop the lagging as my answer below. We dont need to installl Virtual Guest Addition
    – Nam G VU
    Apr 10 '13 at 8:58
1

What are the specs of your PC and what specs did you setup on your guest machine?

Often times the most common issue is to little RAM. Windows 7 is 64bit, unless you were the unlucky bloke that has the 32bit version, and as such requires much more RAM than the older 32bit operating systems. That being said you generally want to give your guest machine at least 4GB if not 8GB of RAM depending on what your PC has to offer.

The lag you are experiencing might look like video lag but it is most likely do to your guest PCs need to constantly move information between the RAM, HHD, and your virtual memory. HHD are normally the bottleneck for most PCs so giving the guest machine enough RAM so it doesnt depend on the HHD as much solves most lag issues.

1

I had to reinstall, install a new version of GuestAdditions. No, the enable 3d acceleration option alone did not do a dime, it was due to not having selected option VMSVGA in Graphics Controller select box in Display section, which was not working properly after changing graphics card or moving my hard drive to another computer where was GuestAdditions installed on the old one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.