I have recently had a hard drive failure so I was forced to reinstall my OS (Windows 7). After a fresh install, I noticed the internet speed became extremely slow (~15 minutes for downloading a 20MB file). I have installed all available windows updates and drivers.

I have a cable connection that is supposed to be 40Mbit, and this was the performance I was getting before the reinstall, as well. Between the modem and PC there is a SMC SMCWBR14S-N2 router.

I have other machines on the network, a PC with Windows 8 PRO which is connected by a lan cable and another Win7 machine that is using wireless lan. Both of these other machines show full performance (40Mbit) when downloading and also on speed tests.

What I have already tried:

  • I assumed this might be caused by a faulty driver, so I tried three different NIC driver versions (Original driver from the Motherboard manufacturer website (v15.37) as well as the latest stable and beta driver from the Nvidia homepage (v15.57 and v15.58). None of these had any influence on the performance
  • Changing the NIC to a different one. I had a PCI NIC lying around, so I installed it. Unfortunately still slow.
  • Changed the cables.
  • I also went to my ISP and traded my modem against a new one. No go.
  • Swapped out all hard drives and reinstalled the OS
  • Connected directly to the modem without a router

I also have Ubuntu installed as a second boot option, and experience full speed with it, with both NICs. If I go back to Windows, it becomes slow again. Here is a comparison from speedtest.net: enter image description here

I have no special software installed. This is a fresh reinstall of windows and it worked fine before the reinstall.

Here are relevant system specs:

  Operating System                        Microsoft Windows 7 Ultimate 6.1.7601.18044 (Win7 RTM)
  CPU Type                                DualCore Intel Core 2 Duo E8400, 3000 MHz (9 x 333)
  Motherboard Name                        Asus P5N-D  (2 PCI, 2 PCI-E x1, 2 PCI-E x16, 4 DDR2 DIMM, Audio, Gigabit LAN, IEEE-1394)
  Motherboard Chipset                     nVIDIA nForce 750i SLI
  Network Adapter                         Realtek RTL8139/810x Family Fast Ethernet NIC  (

I am stumped as to what could be the case at this point. Please help.

  • 1
    @Diogo As stated, I have already installed all available updates. The system is not downloading anything. Additionally, this has been going on for 5 days now. – Satoh Apr 5 '13 at 17:35
  • 2
    This is a long shot, and it should not be the case unless you explicitly set it: but check if the windows driver is configured for half duplex or full duplex (with the Linux installation choosing the other setting). – Hennes Apr 5 '13 at 17:38
  • 1
    Does Device Manager have any missing drivers, yellow or red devices? – Austin T French Apr 5 '13 at 17:49
  • 1
    Any failed Windows updates in Window update history? – Carl B Apr 5 '13 at 19:22
  • 1
    Windows Vista article, but carries to 7. Try autotuning and flow control: windows.microsoft.com/en-US/windows-vista/…, and I've seen IP4 Offloads cause it too. – LilCodger Apr 5 '13 at 22:16

To locate the problem, I would tried by order:

  • to change RJ45 cable and switch cable to another port of the modem, and to try with ubuntu live cd => to remove external hardware issues.
  • If you got your windows 7 image via utorrent, I would tried another one. => to remove potential trojan, spyware, ... issues
  • I will use a software to monitor outgoing connection (windows tools like Little Snitch for Mac, most firewall can do it) => to remove potential trojan, spyware, ... issues
  • Try to sature my bandwidth with ping command line and mesure it with bandwidth monitoring tool => to locate if the problem is only with TCP protocol or not
  • Your Wireshark log shows TCP DUP ACK, I would tried to reduce MTU packet size (tools should exist to do it). => in case of weird communication between your network adapter driver and your cable operator modem. (It shouldn't be that because in this case it would have been worst.)
  • Check my disk with a scan disk => in case windows had been installed on bad sector (?)
  • (Check my RAM, with Memtest86 => shouldn't be useful here)
  • With no other devices connected on the same network and behind a NAT, reinstall a default configuration with every update => If it didn't change, I would suspect a driver issue.

I've noticed that you have an ASUS MB. Are you running the AI Suite? More specifically are you running the Network iControl within that suite? In doing some research about this utility, I found dozens of complaints about internet being slow due to having the Network iControl turned on. The one symptom that you don't seem to have is upload bottleneck which was one of the symptoms that the Network iControl had, so this may not be relevant to you.

While this does not make sense considering that the Network iControl is supposed to help with prioritizing task associated with internet and network traffic, nonetheless there is evidence. I tried it myself because I was curious and I noticed the same issues others had experienced, but again, the issue usually affects both download and upload speeds.

  • I have not installed any of the manufacturer software, only the drivers. I will try installing it though, maybe it will help :P Also, I had the same motherboard before the reinstall, and it was working fine. – Satoh Apr 16 '13 at 13:14

It sounds like your problem is software related not hardware.

  1. What is the browser you're using? Try a different one.
  2. Check the browser settings such as proxy settings, connection, and security settings.
  3. Trun off Windows Firewall and see if there's a difference
  4. Turn off any antivirus software if any.
  5. Run the Windows built in network troubleshooter.
  6. Go to command prompt and run ipconfig /release and ipconfig /renew. Also, ipconfig /fulshdns
  7. Empty browser's cache.
  8. Remove any toolbars if any and disable any add ons.
  9. Install Windows updates.
  10. If the problem is still not solved, install wireshark and capture data while downloading files from the Internet to figure out where is the "bottleneck" happening.
  • Thank you for the tips, but I have addressed most of your points in my question already: 1. This happens in Firefox, Chrome and IE 2. Also happens on programs that do not use HTTP, like uTorrent.No proxy is used. 3. Windows firewall is off and there is currently no firewall installed. 4. No Anti-virus software is installed. – Satoh Apr 11 '13 at 17:56
  • 5. The network troubleshooter says everything is fine, as connectivity is okay, it is only performance. 6. I did this before and also switched the NIC to a different one 7. This issue happens to all programs, not only browsers. 8. Ditto 9. I already wrote I have installed all available updates 10: I will try this, thank you for your contribution. – Satoh Apr 11 '13 at 18:01
  • What exactly should I be looking for in the Wireshark log? There are a lot of TCP DUP ACK and TCP Previous segment not captured messages. – Satoh Apr 15 '13 at 21:48

Long shot, but have you considered the partition your Windows install resides on?

Because your upload is consistent but your download is suffering, I would guess that there may be some 'write' issues occurring on your Windows partition. Perhaps some driver issues on a SSD, or a heavily fragmented or corrupted section.

This also coincides with changing NIC cards and seeing no difference.

Maybe you could test the write speed from a usb or some benchmarking software.

  • As I mentioned in the question, this happened after a HDD crash. I bought a completely new sealed HDD and installed windows on it. I also copied some backed up data onto the new drive, and write speeds were fine. The other two machines get normal speeds, so it is unlikely that something is stealing bandwidth. I am going to install windows on an old small drive and switch it out with the new one, to rule this out. – Satoh Apr 18 '13 at 0:15
  • Let me know how it goes. We can rule out hardware issues with the NIC/slot, cabling and modem. Drivers are probably OK because of the regular upload. The adapter settings may be wrong (all though you ruled out duplex), but something is affecting download only. Your latency stays consistent so I conclude it must be the incoming transfer of a file. Whether it be anti-virus or HDD issues, or something else related, it'll take some guesswork. – Blego Apr 18 '13 at 18:15
  • Unfortunately, even installing on a different hard drive does not help. I would just write the board off as broken if it wasn't for the fact that it runs under linux. – Satoh May 30 '13 at 12:41
  • I guess all that leaves is the Windows install. Try a different image and/or OS and/or package(ultimate/pro). – Blego May 30 '13 at 16:43

If you are plugged in via ethernet directly, make sure your wireless is not also turned and connected to the network (or any other network). This can cause interference in Windows.

If you torrented your copy of windows, definitely check to make sure you're not using network resources for other nonsense. And especially if you did that, but in either case, you should check what DNS you are using and perhaps try changing it, if it is not the same one you are using in Ubuntu.

Not the answer you're looking for? Browse other questions tagged or ask your own question.