27

I've got Oracle VirtualBox 4.2.10 installed on Ubuntu 12.04, and with evry virtual machine I create, the "host key", which is supposed to release the mouse doesn't do anything. I've already installed the Guest Additions Expansion Pack (or whatever it's called,) and that didn't fix it. What else should I try?

P.S., not a duplicate of Right Ctrl release does not work - that one is in Windows 7, this one is in Ubuntu 12.04. The answer to that one is inapplicable to this one.

2
  • 1
    In the VirtualBox Manager, under Settings -> Input, ensure that your Host Key is set correctly, and that Auto Capture Keyboard is unchecked (you can change it afterwards to your preferred setting, but check to see if anything was changed to begin with). – Breakthrough Apr 7 '13 at 12:18
  • I was pressing right cntrl continuously and later found that it is left ctrl. Are you doing the same? – InQusitive Nov 30 '15 at 17:49
28

to return ownership of keyboard and mouse to your host operating system, VirtualBox reserves a special key on your keyboard for itself: the "host key". By default, this is the right Control key on your keyboard; on a Mac host, the default host key is the left Command key.

5

Have you set your release key to something else and forgotten about it? I believe the default key is the right ctrl key, but you can also set your own.

3
  • No, I haven't messed with it at all. It still lists Right CTRL as the Host Key in the lower right hand corner... – JamesTheAwesomeDude Apr 7 '13 at 4:47
  • Maybe try changing it to something else like one of the function keys – J.Miller Apr 7 '13 at 4:49
  • For me, changing from Right CTRL to left CTRL worked fine. – Bala teja Jun 11 '20 at 17:02
0

Post 11:44 AM Friday November 27 2020

During my installation setup I added my mouse with, USB filter into -> Setting -> USB. out of silly mistake, due to this I had to result going into many forums to look for an fix* if your like me remove the filter. other wise try R+RCTRL if this didn't work, add a custom mouse integration in File -> Preferences -> Input -> TAB: Virtual Machine & Look for: Mouse Integration.

0

If [auto capture] is checked, your host mouse will stuck on your virtual box. go and uncheck this. go input>keyboard>keyboard sitting.

0

Fixed my mouse capture by Unchecking it in the USB selection. Hopefully this helps others.

image of settings pane

0

For a troublesome Vagrant-generated guest machine running a Linux server distro without graphics which doesn't respond to the other solutions here: With the [text] console of the guest machine (where it is still possible to type), shutdown the guest with sudo shutdown -h now ; the guest machine halts and removes itself from the screen, which returns mouse and keyboard control to the the host PC (in my case I was having to login before I could issue the shutdown command; reminder: default vagrant credentials are vagrant/vagrant)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.