5

I was searching for a solution which will help me to disable URL auto suggestion (from history) while I type URL on address bar, but I haven't found anything about this solution. I tried to uncheck

Use a prediction service to help complete searches and URLs typed in the address bar

in privacy settings, but it doesn't help.

Is there any way to disable history or disable URL suggestions from history?

1

Any of these two extensions will do the trick:

  1. History Disabler: Completely disable browsing history in Chrome. It uses the lowest possible memory, only running when history needs to be removed. This extension disables both history, and the 'Recently closed' menu. It also allows for download history to be disabled.
  2. History On/Off: This extension acts as simple on/off switch. Click the button and you'll turn off history. Click again and history recording will be turned back on.

Both extensions will only disable history recording, but it doesn't deal with cookies, local storage, browser cache etc.

0

try this:

Try this:

http://productforums.google.com/forum/#!category-topic/chrome/discuss-chrome/J6AGhiwOpF4

(found here: http://www.google.com/support/forum/p/Chrome/thread?tid=6501481bab1c67eb&hl=en )

  1. Go to your google Chrome icon and right click then hit properties.
  2. Click on the shortcut tab
  3. Where it says target, at the end of that line put a space and add “-omnibox-popup-count=1” without the quote.

With the "Use a search suggestion..." unchecked and the target option in #3 above, the bookmark search isn't displayed (sort of like hiding the Awesome Bar in Firefox). Oh, and put the target option on the outside of the Chrome path on the target tab ("C:[PATH ON YOUR COMPUTER]\chrome.exe" -omnibox-popup-count=1).

Until (or unless) turning off the Omnibar is an option, this works.

  • 1
    what this issue has to do with omnibox? omnibox is for search predictions – Tural Ali Apr 7 '13 at 13:17
  • @TuralAliyev The Omnibox is Chrome's name for the address bar/search box/etc at the top of the Chrome window. – cjb110 May 30 '14 at 14:02
0

Not really an answer to your question but you can press Shift + Del to delete individual entries from showing in your omnibox once they are highlighted.

0

To disable URL suggestions from "History":

  1. Download & install the simple utility "Easy File Locker" from this location http://www.softpedia.com/get/Security/Lockdown/Easy-File-Locker.shtml
  2. Open "Easy File Locker" & use a master password...
  3. Close Chrome.exe
  4. Go to this location on your PC C:\Users(username)\AppData\Local\Google\Chrome\User Data\Default and look for two files named "Archived History" & "History"
  5. Drag these two files inside "Easy File Locker" and double-click on individual files & uncheck all four check boxes.
  6. Open Chrome.exe and now at start-up chrome will notify you that some profile couldn't be loaded.. it's okay..because we blocked access for its History files(that's our intention)
  7. Try visiting some pages & close all tabs..now open a tab and type a URL in Address bar(that you had already visited).. now it won't auto-suggest.. and also it won't display the history list using chrome://history/ unless you unlock those two files in "Easy File Locker".
  8. "Edit->Toggle Status" will unlock these two files easily in "Easy File Locker".
  • While not the most elegant solution, this would solve OP's problem, so I'm not sure why it's being downvoted. – Jon Apr 30 '18 at 20:37
-2

I think Removing past searches from Google Chrome's omnibar might help you. Although, know that this solution involves using sqlite browser to manually delete autocomplete suggestions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.