I have a laptop(Sony Vaio VPCSA9e) (OS: Windows 7) and a monitor (LG W1945S). I used to connect the monitor to my laptop in 1440X900 screen resolution without any problem. (I connect it via VGA cable.)

But, somehow, when I now connect the monitor, the screen resolution is 1024X768 and I cannot change. I also recognized that "Device on VGA" is selected for display option instead of W1945 as before.

There are some problems similar to mine in the Internet and I have:

1) Updated graphics drivers

2) Updated monitor driver (I ensured that default screen resolution is 1440X900 in .ink file)

3) Tried with another VGA cable.

However, none of them didn't work. Do you have any suggestions ?

  • go to [ Control Panel\All Control Panel Items\Display\Screen Resolution ] and tell what BOTH monitors are saying there in resolution (click on the pic for each) And tell us what it says now in the "Display" field for the external. Then push on the "Advanced settings" button there, and see if you can find the refresh rate also. – Psycogeek Apr 8 '13 at 17:17
  • As I said in the question "Display" field is "2.Display device on: VGA" for the external. Display rate is 60Hz. – Berk Apr 8 '13 at 18:13
  • But, I also made an important observation. When I go to Control Panel\All Control Panel Items\Display\Screen Resolution\Advanced Settings-Adapter\List All Modes, there is no mode with 1440X900 resolution. I think the problem is related with graphics adapter rather than the monitor driver. But, I already updated it and followed :norhazlan.blogspot.com/2009/11/… – Berk Apr 8 '13 at 18:16
  • what is the resolutions shown in both now? Yes you said that, but indicated that you tried to get a monitor profile on in #2. Because I cant see anything, I have to ask you. – Psycogeek Apr 8 '13 at 18:19
  • I think your right, that something might still be amiss with the grafics driver software stuff. You already hacked it with some blog info? Weird, that anyone would have to do that, when most laptops are setup to use an external, and as long as it is not "cloned" desktop there should be no problems. – Psycogeek Apr 8 '13 at 18:27

Okey, I solved the problem. It is due to VGA cable as pointed out in prior questions. I was unlucky because my second VGA cable did also not work. Bingo in third!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.