1

I bought a new Toshiba P850 laptop with Windows 8 OS and a 1 TB Toshiba USB HDD. I copied all my files from my old laptop to USB HDD successfully. Then I started to move from USB HDD to my new laptop. Most of the files moved without an error. Then I saw that coping speed dropped to 0 kb/s. I canceled it but the window of file copy was still there. I closed it with the [X] button. But there still sounds were coming from the internal HDD. When I check the task manager I saw a heavy load on the internal hdd. I reboot and retried moving the files that are still on the USB HDD. The same thing happened again after 10 seconds of file transfer. I did many restartings and deleting control driver of USB but nothing fix the problem.

Then I thought maybe Windows Explorer file copy system in Win8 was buggy so I tried my favorite window manager Total Commander. It was freezing after a couple of seconds like Windows Explorer. I don't know why I tried but I opened a second window of Total Commander and started moving another folder from USB HDD to internal HDD. This time it didn't freeze and very interestingly the first file moving process of TC that was frozen, also started working. It was insane. I waited till it finished. After one of the process finished the other one frozen again. If I move another folder from the other window of TC frozen one was going on transferring again.

Then I tried to move a folder with Windows Explorer again until it freezes. When I move a folder from TC, frozen process of Explorer was also starting to work normally.

How can this be?

  • 1
    This isn't a bug in Windows I an guarantee that without a shadow of a doubt based on my 20 years in the industry. USB 2.0 or USB 3.0 and have you tried a different USB port? This sounds like a hardware failure. – Ramhound Apr 10 '13 at 12:04
  • @Ramhound After I moved everything to my new laptop I copied some files to USB HDD and try to move again to my laptop. I couldn't reproduce the bug. – borayeris Apr 10 '13 at 13:49
  • Your comment has no context please explain it. – Ramhound Apr 10 '13 at 13:51
  • Explain what??? – borayeris Apr 10 '13 at 13:53
0

I don't know if I am correct but I think maybe one of the files or folders on your USB HDD was not correctly saved and had an i/o error? I suppose your should get a message from Windows saying something but maybe it just hung?

This explanation seems to be backed up by the fact that moving another folder from your USB HDD in a new TC window worked without problem.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.