2

I am living in a house where we are sharing an internet connection.

I also have a small server (HP Proliant N40L running WHS 2011) that will be connected via cable to the main router/wireless access point in my room. I would if possible like for it to be invisible to those that are connected to the access point and browsing the network.

I have run

net config server /hidden:yes

on the server, but if I open the Network window on my other pcs, the server still shows up:

enter image description here

Is there a way to solve this?

Added info

Network location is set to PUBLIC on the server

In advanced settings for the public network profile

  • Network discovery is OFF
  • File and printer sharing is OFF
  • Public folder sharing is OFF
  • Media streaming is OFF
  • Password protected sharing is ON

Server was rebooted after the network profile settings were made and the net config command was run (although I don't expect this should be necessary)

  • Doesn't your router allow splitting off the wireless network from the wired, to completely separate the wired & wireless networks? Sometimes also the wireless can be split off into two networks : normal wireless on same segment as the wired, and Guest which is totally isolated. – harrymc Apr 13 '13 at 9:37
  • Router interface does not show any options for that. It is also a shared connection, so I am reluctant to change router settings. And I am mostly curious about how Windows broadcasts its presence! – mxl_ Apr 13 '13 at 10:21
  • I can see your server is successfully invisible, except that it shows up as a media device (this is WHS after all). If you wish to stop this, you can in the WHS Console / Settings turn off Media Sharing (turn off for all directories) and in Services disable the Windows Media Connect Service. Also in Network and Sharing Center / Homegroup and Sharing Options / Media Streaming Options, set to Block All. As I'm not running WHS I can't test my own advice, so the above might be too much or too little. – harrymc Apr 13 '13 at 13:15
  • That was half the answer! After going Windows Home Server Dashboard and turning off Media Server there it no longer appears under "Media Devices" in Network, but remains under "Other Devices". Tried your other tips - since my network location is set to public, it does not show any Homegroup and Media Streaming options. I went into services and disabled the Windows Media Player Network Sharing Service; there is no other "Windows Media-" service. It seems like the Other Devices section relates to something more than media services. – mxl_ Apr 13 '13 at 14:00
  • Do you mean that Other Devices is still there ? Try also to disable the UPnP Device Host service. – harrymc Apr 13 '13 at 18:29
1
+50

I can see your server is successfully invisible, except that it shows up as a media device (this is WHS after all). If you wish to stop this :

Disable Media Devices

In the Windows Home Server Dashboard, turn off Media Server.

Disable Other Devices

In Control Panel / Administrative tools / Services, disable the UPnP Device Host service.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.