I'm having problems keeping my Windows 8 clock synced so I'm trying to regularly resync with an every-5-minutes schedule trigger.

When I go into the Windows 8 task scheduler through the Administrative Settings control panel, it all seems to load fine. Also, the Task Scheduler service is running (and can't be stopped). If I navigate to the pre-existing Microsoft/Windows/Time Synchronization/ForceSynchronizeTime task, everything loads. If I right-click and open the Properties for that item, it all loads fine. But if I try to "OK" out of the properties window, having made any changes or not, I get this message box and the window won't close. I have to X out.

I'm not even sure that this will work to mitigate my clock drift issues because the clock will suddenly drift backwards in time and stay there. Depending on how all these mechanisms fit together, the scheduled tasks to resync the clock might be affected too!

This machine was a from-scratch install, not an upgrade.

enter image description here

This is not a dup of Windows Task Scheduler broken: “service is not available”

  • Could it be disk corruption? If so try Sfc /scannow.
    – Guy Thomas
    Apr 14, 2013 at 13:15

3 Answers 3


I had this same error message on Windows 10. It affected only one of my Scheduled Tasks.

The solution in my case was to remove the Network Connection condition that I had defined in the task (on the Conditions tab).

Source: Comment from user 'Ron' on this thread: https://www.kapilarya.com/fix-task-scheduler-service-is-not-available-in-windows-10

  • Changing it from a specific network to just Any connection worked for me. Mar 26, 2019 at 14:57

The easiest way to fix this problem is just to either create a new task or (easier since you may not have a new task at hand): 1. look at a current task in the task scheduler 2. write down all its settings 3. Delete the task 4. Recreate the task

Once you do this everything seems to work again! :-)


This link has instructions:


Turns out I needed to just create a brand new task rather than try to use the built-in one.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .