I am now having a DNS issue for sure. When I ping ComputerName it tries to ping ComputerName.DNS suffix

But this suffix doesn't have any resolution on my network. The DNS servers are all external.


I have two Windows 7 PCs. They can see each other in the network list, but I can't seem to connect them beyond that.

I even tried using a Homegroup and even though the folder (library) I shared showed up, I couldn't open it. One of the printers did share properly.

I really just want password-protected sharing. This is for a multi-user quickbooks file.

I have all users on both computers with identical passwords. No DC. I'm using pFSense for routing.

I also tried adding a static line to lmhosts.sam files and setting static ips. No dice.

When I run nbtstat -n I don't see the other computer (even though it shows up in the network list).

At one point, I was getting to an actual password prompt, but I wasn't able to enter any credentials.

I'm looking for a solution that bypasses the router/dhcp/dns possibility as settings I've had success with before throw other assets on the network into chaos.


migrated from serverfault.com Apr 12 '13 at 6:48

This question came from our site for system and network administrators.

  • Go to control panel, user accounts, manage credentials. You can set up credentials there for specified host. – Alan Kuras Apr 12 '13 at 6:24

Do they actually have connectivity to eachother, beyond the network discovery? Can you ping from one machine to another?

If they have connection via IP - what happens if you traceroute it? Could it be a firewall blocking the sharing or issues with the routing? Are they on the same network/subnet?

If you have local credentials, can you connect to \\computer1\c$ from computer2 (This would use the local credentials on computer1)

When you have confirmed connectivity, you could create local accounts on each machine for accessing the share. They could even be hidden from the Windows 7 loginscreen if you want: More infomration on how to do that here.

  • Yes, they do have ip connectivity. I've tried \\ComputerName, but I haven't tried \\ComputerName\Share yet. I do have local accounts set up that are identical on each machine. – Stephane Apr 12 '13 at 13:37
  • I can connect with \\ip_address, but still not with smb/netbios/whatever – Stephane Apr 12 '13 at 14:25
  • I added an edit. Maybe that will help. – Stephane Apr 12 '13 at 14:52
  • Do both the computers have the same DNS setup? Are both set to use external DNS servers? You could use a work-around to get past this, but it's really not reccomended. – xstnc Apr 15 '13 at 12:14

Here's what I ended up doing. I'm not sure which of these is 100% necessary:

  1. Turned off ipv6
  2. Made each computer have a static ip/DNS
  3. Confirmed that DNS Suffix isn't set (Computer Name->Change->More)

It worked immediately.

So, there's something wrong with my DHCP server with how it binds addresses, but for now, this will work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.