95

Is there any easy way to listen to the input on a Mac?

For example, assume I have a microphone hooked up to the input (i.e. line in) of my Mac, and I have headphones hooked up to the output of my Mac: is there any way that I can hear what I say in the microphone through the headphones?

This is very easy in Windows XP: simply go to the sound settings for recording devices, check "select" on the line in, and increase the volume – this makes it so you can hear what is said into the microphone.

It has to be in real time; a solution where you record the input and then playback the output later doesn't help.

  • 1
    I know this is (years!) old, but you may want to update the accepted answer to the one about QuickTime Player. Line In has substantial buffering/delay issues (when you restart, it's fine, but after a few minutes, it creeps back in) plus it's a third-party app let alone one that's no longer supported by them. Using QuickTime Player however, it's part of the native OS, there seems to be zero delay, and you get a volume control to boot! Anyway, just throwing that out there Hope it helps! – Mark A. Donohoe Sep 20 '18 at 0:43
69

Take a look at Rogue Amoeba's LineIn. It is a free application which will allow you to do what you want.

| improve this answer | |
  • 1
    LineIn can select line-in/mic/digital-in etc, and there are independent volume control. – deddebme Oct 21 '09 at 5:39
  • 7
    delay introduced is significant. I'd love to see a LineIn-like app working with fast ASIO drivers of the available soundcards. – Serg ikS Aug 28 '14 at 7:07
  • 3
    Rogue Ameoba released version 2.3 on 2014.09.03 that has completely eliminated delay. – xizor Sep 24 '14 at 23:00
  • 1
    Currently the free version stops working after 10 mins. I was about to try it anyway but had trouble downloading it. Then I found lifehacker.com/5630844/…, which works. – Ryan Mar 27 '17 at 14:16
  • 1
    Replaced by rogueamoeba.com/audiohijack – grappler May 10 at 20:33
59

With 10.6 (and newer, AFAIK) you can launch QuickTime Player.app and choose File -> New Audio Recording. Then just turn up the volume control that is part of the window that appears. You might hear a bit of white noise when there's no sound and the volume is all the way up but the Rogue Amoeba app does the same thing.

Open File menu and select New Audio Recording Increase the volume rocker at the bottom of the windows

| improve this answer | |
  • 3
    MAN, I wish I had found this a while ago! This should be the answer, not Line In. This is part of the OS. That's not only third-party, but currently it's legacy, but worse, the biggest issue with 'Line In' is it tends to start to buffer the input, so for instance, using it to route my TV's sound through my computer, it routinely gets out of sync. That doesn't seem to happen with this method. Plus... volume control!! WOOT! – Mark A. Donohoe Sep 20 '18 at 0:36
  • 8
    There's a ~30 millisecond delay when using this method. – Merchako Nov 27 '18 at 20:34
  • 4
    I'd go so far as to say its a 500ms delay ... Not really workable. Could this be because it's a bluetooth headset with a mic? – Michael Apr 2 at 19:25
  • 1
    I have the same delay with the built in mic and wired headset. – Hans Kristian May 5 at 7:40
  • I also get a delay of hundreds of ms. The meters on-screen move long before I hear the sound through my wired headphones. – Josh Aug 17 at 22:58
14

You can also use Garage Band. Choose for example the Acoustic Instrument template (the default audio track in it has no effects) and set monitor to on.

| improve this answer | |
  • this seems to work just as well as linein, maybe a bit better – chrismarx Nov 9 '14 at 0:09
  • Check out the QuickTime Player approach. Even better/simpler and zero lag! – Mark A. Donohoe Sep 20 '18 at 0:39
14

As originally suggested by qu1j0t3, Apple's "AU Lab" provides the ability to listen to the audio input in real-time. (Well, nearly in real-time; for me there is a slight delay from input to output.)

(If those links die, it can also be downloaded from Apple Developer Tools, which may require an Apple Developer account.)

Usage:

In the Document Configuration window, select the existing "Stereo In/Stereo Out" configuration. (If the Document Configuration window is not already open, click File → New to open it.) Then click the Create Document button in the bottom right corner.

In the new "Untitled" window that opens, ensure the icon at the bottom says "Audio Engine Running" (or click to toggle if it says "Audio Engine Stopped"). If necessary, adjust the system's overall input and output volume settings in System Preferences → Sound → Input.

| improve this answer | |
  • 1
    Another answer already mentions AU Lab. Your answer is better because it basically follows this outline while the other one does not. – Kamil Maciorowski Sep 15 '18 at 6:09
  • @KamilMaciorowski Yes, you are correct - AU Lab was already mentioned in a previous answer, so I have edited mine to mention that. I would have commented/added to the previous answer, but I don't have enough reputation and my suggested edit was rejected, with the reviewer recommending that I add it as a new answer instead. (Sorry, noob problems, not really sure what etiquette I should follow.) – Chris Tollefson Sep 15 '18 at 23:36
  • 1
    This is a good solution and well explained. The problem is (or at least was for me) that Xcode is currently only available via MacAppStore and one has to use the latest macOS to download it. But luckily Apple still provides AU Lab on this iTunes-Site I found: apple.com/itunes/mastered-for-itunes – alex r. g. May 9 '19 at 21:19
  • 1
    Signed up to SuperUser to vote you up! ... I needed this for client calls because my headphone are too good at blocking out residual sounds so I was constantly shouting. When I used them in bluetooth mode there was a considerable delay but using them in wired mode this works perfectly. – compuphys May 5 at 12:17
  • 1
    Both this and the Quicktime answer worked for me, but the Quicktime answer had maybe a 0.5s delay, and this one had no delay, which makes it a lot more natural. My microphone is mono, so I first had to create a new configuration (+ sign at bottom) with mono input and stereo output. Then it worked well. – Matthias Fripp Sep 8 at 21:33
6

If you're using an older Mac, the application Audio MIDI Setup.app in the Utilties folder (found in the Applications folder) allows* the ability to pass-through input straight to your output.

To do so; click on your input device and then check off the "Thru" checkboxes to pass audio through. However oddly enough I've never seen anyone to get it to correctly work on an Intel based Mac, I've had it work great on some PowerBook G4s however.

The better alternative is to use Rogue Amoeba's LineIn (as said by Richard Hoskins). Personally I use this and find it easier to use.

| improve this answer | |
  • 7
    Using Intel based Mac.. can't check the 'thru' checkbox.. looks like it is disabled. – Umair May 24 '15 at 18:44
  • 1
    This only controls the analog passthrough in a single device/sound card, it will not connect one device to another through software. – endolith Nov 19 '15 at 16:24
  • I tried LineIn it's free and does the job. Still a bit of echo but less then with SoundSource. – eloone Jul 7 '17 at 21:13
  • Have you tried the QuickTime Player trick above? That seems to do the trick great! Not only is there no delay, but you get volume control to boot! – Mark A. Donohoe Sep 20 '18 at 0:41
6

Another option is "AU Lab" in Developer tools (Developer/Applications/Audio/AU Lab).

| improve this answer | |
  • 1
    I couldn't find this in the Xcode developer tools, and had to download it from the Apple Developer website. – evolutionxbox Jan 29 at 15:09
5

If you want to use the terminal, you can install sox (i.e. with Homebrew brew install sox) and then run

sox -d -d

Here, -d means "default audio device", and this command specifies it for both the input and the output, i.e. microphone and speakers/headphones.

You can decrease latency by decreasing the buffer size (default 8192), try what works for you:

sox --buffer 1024 -d -d
| improve this answer | |
0

I tried several things and was getting pretty frustrated until I discovered an old 2010 article by Adam Dachis about using AudioMonitor, part of MTCoreAudio’s developer package for Apple products. (You can download MTCoreAudio for Mac for free at https://mac.softpedia.com/get/Developer-Tools/MTCoreAudio.shtml.) It works perfectly on my Powerbook (OS El Capitan). Once opened up, just click on "Play Through". Now when I travel and my wife or I want to watch Hotel TV while the other doesn’t, to use headphones (you'll need to bring along a fairly long mini plug cable) she or I can just plug my laptop into the TV’s “speaker out” port via the computer’s line in mini plug port (my laptop has two mini ports, unlike the newer models) and the headphones into the computer’s audio out port. The sound is perfectly synched to the TV (no delay) and to avoid any irritating white noise in the background we simply unplug the computer’s power cord and run it on battery mode. Much better than Quicktime (delay) or any other trick I tried.

| improve this answer | |
  • For those who are having issues with the softpedia website, here is the program's github page. Simply click the "Clone or Download" button and then click the "Download ZIP" button. Extract the ZIP file and you will see the AudioMonitor.app file. – flamewave000 Jan 31 '19 at 15:54
  • The AudioMonitor.app (downloaded from Github) doesn't appear to be compatible with macOS Catalina. :-( – HaggleLad Jun 10 at 20:21
0

2020 Update:

Best way: I have an mbox with a condenser mic. When I run the audio thru that, 0 delay and your headphones can be true monitors. I bought a Snowball for ease tho, its a lot to setup.

My solution: Garage band had the best delay for me. Open garage band in the background. Create an audio track and turn on the monitor icon on the track. Shut off any effects.

Easiest solution: Audio Hijack was next best. Its 60 bucks but seemed like cool software if you had more to use it for. Good be noticeable delay. https://www.rogueamoeba.com/audiohijack/.

Free:* Sox but it had a surprisingly long delay for a CLI. See @billfraser's answer

| improve this answer | |
  • Pro tip, unless you've got an external audio device, cover one ear when recording. It makes the delay less noticeable as you're getting the real time sound in your skull then the input after. – cjohndesign Sep 1 at 17:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.