0

After upgrading my Debian unstable to Kde 4 a few months ago, the Flashplayer started to be very slow, especially in the full screen mode. Using Kde 3 I was able to watch full screen Youtube or IPlayer, but now the frame rate is somewhere around 10 fps. Is there a way to improve it?

1

xkcd 619

  • Yeah, this is so true! – Grzenio Sep 2 '09 at 17:57
1

On KDE 4, go to System Settings > Desktop Effects, Advanced tab, check "Suspend Desktop Effects for fullscreen windows".

| improve this answer | |
0

There's a few things that could come into play here such as which browser you are using, which flash plugin it uses and whether you changed your video card drivers at the same time you upgraded to KDE 4.

I'd recommend switching browsers and seeing whether that helps (at least narrows down the problem). So if you use the built-in konqueror, then try firefox (or vice versa). My guess would be that firefox with the Adobe Flash Player would perform better then konqueror with the free flash player...

| improve this answer | |
  • I don't think iPlayer (which is something I use the most) works with the free players... Anyway, the only thing I did is upgrade kde from 3 to 4, without touching drivers or flashplayer, and the performance deteriorated. I guess that is has something to do with the new 3d effects in KDE 4, hopefully someone already had this issue. – Grzenio Jul 15 '09 at 15:25
0

It is likely an issue with your drivers. I had a similar problem where KDE 3 would work fine with any Flash sites. Upgrading to KDE 4 had a similar problem to yours; it got very slow, especially the bigger the flash module.

In my case the computer has a UniChrome video card, and forcing it to use the drivers fixed the problem. I don't know why I didn't have to do the same in KDE 3, but it worked for 4.

| improve this answer | |
  • How can I check this (I have an nvidia)? – Grzenio Jul 18 '09 at 7:55
  • In the Screen section of your xorg.conf file should be set to the same as what your video card is. You can find out what your computer reports the video card is by using lspci in a terminal window. It won't necessarily be exactly the same. – Joshua Nurczyk Jul 20 '09 at 3:39
0

Sounds like hardware video scaling is not working. You may try to disable desktop effects and see if that improves the performance. Go to System Settings, Desktop and uncheck Desktop effects.

| improve this answer | |
  • Ddin't work unfortunately - plays fine in small size embedded in browser, but drops to 10 fps full screen. – Grzenio Jul 18 '09 at 7:47
0

Have you tried disabling compositing in KDE before launching the FlashPlayer? Just press SHIFT+ALT+F12 to disable it temporarily.

| improve this answer | |
  • Tried it, but to be honest I haven't seen any difference. Maybe my graphics card is too old (GF6800)? – Grzenio Sep 21 '09 at 9:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.