0

I am unable to get output when I run help... in Powershell version 2.0. Server 2K8R2 SP1. Get-Help... works as expected.

  • 1
    Do you get any output if you type (dir function:\help).definition at the PS prompt? – Karan Apr 12 '13 at 19:24
  • Yes. I get the .forwardhelptargetname and .forwardhelpcategory along with the parameters. – winarm Apr 12 '13 at 21:02
  • That's weird. Since the function seems to be present I've no idea why the help command is not working. – Karan Apr 12 '13 at 21:09
  • 2
    Try Get-Command help and see if there are no aliases defined. Also - try to run PowerShell without profile (powershell.exe -noprofile) and check if same behavior is visible also there. – BartekB Apr 14 '13 at 9:14
  • It works now. The server was not restarted, so there is nothing that changed over the weekend; uptime is 27 days. The get-command shows the function and application CommandType. Everything works as it should. Weird. Thanks for the suggestions. – winarm Apr 15 '13 at 13:44

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.