Running XPages in Notes Client (XPiNC) the same way as XPages are run when you access them with web browser (without any local HTTP task) is a feature that I requested about 3 years ago. It finally arrived in Notes/Domino 9.

The feature can be enabled in Application Properties "Launch" tab by checking [x] Run server-based XPages applications directly on Domino server check box. The strange thing is that "Open Designated XPage" launch option must be selected for this check box to become visible. Anyone knows why? This limits the usability of this feature quite much.

I have been trying to configure my Notes client to use this new feature as instructed in help and wiki. Basically I need to create a HTTP account in Notes client Preferences. First I tried without this account, then I created the account and have been experimenting with all account settings but the result is always the same. I get this page:


OK, I'm in China now! There is no HTTP request in domlog.nsf of the server so it really takes me directly to some strange Chinese web page. I did a full virus and windows defender scan on my computer and they found nothing. I also uninstalled my Notes clients and reinstalled to a new folder. The next question is how do I know in which URL I am now?

The most unclear field in the HTTP account setup is "Server:". This is what the help says:

In attempting to honor the request to the XPages application on Domino, XPages iterates through all the Notes accounts defined in the Notes client installation until it finds an HTTP account that matches the name of the server where the application resides

The field accepts only URL starting with http:// or https://. Which host name should I use here? We have a lot of Web Site documents, does it iterate thru all of them? I figured it must be the HTTP_HostName from server doc but as said the result is the same no matter what I try.

Has someone gotten this new feature to work?

Update 1

I tried this now with an application that is on 8.5.3 server and adjusted the HTTP account to point to that server URL. Again I got a strange page, this time a different one. The page title is My_domino_server_name.com where My_domino_server_name is the Notes name of the Domino server, not the HTTP host name. If I go to this URL with a browser I get same looking page but not exactly the same.

So the problem seems to be that it uses the Notes name of the server in the URL.

Update 2

I tried to open the application on another PC where no HTTP accounts have been defined. The result is exactly the same. Looks like it's not finding the HTTP/HTTPS account.

Update 3

When the application is opening there is this text on the screen: "Loading My Application on my_domino_server...". Again my_domino_server is the Notes name of the server, not the DNS host name used for HTTP.

Update 4

I have a PMR open with IBM and they confirmed it works for them with "Server" field value http://domino_server_notes_name/ (with no dots anywhere!). Of course that can only work in intranet. At this point I refuse to believe that the feature has been implemented in such a stupid way but we'll see what is the final outcome from IBM.

  • Panu

2 Answers 2


The 404 shows that you reached the server properly (we don't have a hand in a local database). If your server URL (when accessed by a browser) is http://apps.myserver.com/x_apps/xapplicationdemo.nsf then your account document needs to show http://apps.myserver.com you need 2 account documents if you use http and https. You can point an account document to use the credentials of a "root" document (basically just another account), so you need to enter credentials only once. When you configure Notes for Connections, that's exactly what happens.

Did that work for you?

  • Thanks. I believe I'm not reaching my Domino server because there is no hit in domlog.nsf (in addition to the fact that there should be no pages in Chinese in my server). We have about 10 host names for this server. The host names are specified in multiple web site documents and I wasn't sure if I can pick any of them but I've tried some of them too. I've tried both HTTP and HTTPS URL in "Server" field but I guess I wouldn't need two accounts to get it to work with HTTP. Apr 15, 2013 at 7:42
  • Btw are you saying it works for you? If yes can you share some details like which host name you are using and what type of authentication? Thx. Apr 16, 2013 at 11:12
  • Do you have a connection document to the server?
    – stwissel
    Apr 16, 2013 at 14:49
  • Yes, a normal TCPIP connection document with IP address. Apr 16, 2013 at 14:50

Got more info from IBM: there is a third setting that needs to be in place for this to work! You need to set up the application to run XPages from server in Preferences -> XPages Performance -> Run the following XPages applications directly from server. This is not mentioned in Notes help (or anywhere) as far as I can tell.

I got it working when I added this! But you still need the launch option. Based on my tests if I remove that option it will not run any XPages from server. Looks like the setting is in effect only for the XPage that is launched based on the launch option and probably the XPages that are opened from that XPage. SPR #RGAU972LZA has now been created about this and there will be a technote about the third step which is not included in Notes help.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .