0

I have Linux Mint 14. I was advised to change my Konsole setting, and I must have done it wrong. I tried to change Profile->General->Command from /lib/bash/ to something else. Now when I try to launch it from the GUI it closes right away. I can launch it as root and su to myself. When I try to launch from there I get:

joe@Mint ~/Documents/workspace/archive $ konsole
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave

Is anybody familiar with this problem and its solution? Thanks.

1

The error message has nothing to do with your problem. It is because you are running a KDE app and you are not (I guess) using KDE. Your problem is the setting you changed. You have set konsole's SHELL to something that is not a shell, to fix it, you will need to edit a configuration file. If you have not changed the name of your default profile, that file should be $HOME/.kde/share/apps/konsole/Shell.profile.

So, open that file in a text editor (for example, gedit):

gedit ~/.kde/share/apps/konsole/Shell.profile

In that file, you will find these lines:

[General]
Command=/bin/WHATEVER_YOU_SET_IT_TO

What you need to do is change /bin/WHATEVER_YOU_SET_IT_TO to point to /bin/bash again. Then save the file and try to open konsole again.

| improve this answer | |
  • No luck, in fact the file you sent me to was blank. – user1810434 Apr 13 '13 at 18:37
  • In that case, you have probably changed the profile name. Could you post the output of ls $HOME/.kde/share/apps/konsole/ please? – terdon Apr 13 '13 at 18:42
  • Thanks @terdon. I found the settings file under a different name. All set. – user1810434 Apr 13 '13 at 19:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.