I just installed Linux Mint 14 Cinnamon on my laptop, but I can't find where to connct with wifi, I Googled about it and I found that I've to enable my wifi adapter in Software Sources, so I did enable it and then I restared my laptop, but this didn't solve my problem. When I open Software Sources again I find that my wifi adapter is not enabled.

When I log in to my session, I get a notification which says :

Network Disconnected - you are now offline

My wifi adapter is a: BCM4312 802.11b/g LP-PHY

This is what I get when I run the command iwconfig :

lo        no wireless extensions.

eth0      no wireless extensions.

When I tried to install this package firmware-b43-installer_015-14_all.deb, I got this message :

Selecting previously unselected package firmware-b43-installer.
(Reading database ... 139679 files and directories currently installed.)
Unpacking firmware-b43-installer (from .../firmware-b43-installer_015-14_all.deb) ...
dpkg: dependency problems prevent configuration of firmware-b43-installer: firmware-b43-installer depends on b43-fwcutter (>= 1:015-14); however: Package b43-fwcutter is not installed.

dpkg: error processing firmware-b43-installer (--install): dependency problems - leaving
unconfigured Errors were encountered while processing: firmware-b43-installer

After that I installed b43-fwcutter, and then I tried to install the package firmware-b43-installer_015-14_all.deb but I got this error :

An unsupported BCM4312 Low-Power (LP-PHY) device was found. Use b43 LP-PHY firmware (firmware-b43-lpphy-installer package) instead.

So I removed firmware-b43-installer_015-14_all.deb using Synaptic Package Manager, And then I installed the package firmware-b43-lpphy-installer, but I got this message :

(Reading database ... 139686 files and directories currently installed.)
Unpacking firmware-b43-lpphy-installer (from .../firmware-b43-lpphy-installer_4.174.64.19-4_all.deb) ...
Setting up firmware-b43-lpphy-installer ( ...
--2013-04-13 18:52:14-- http://downloads.openwrt.org/sources/broadcom-wl-
Resolving downloads.openwrt.org (downloads.openwrt.org)... failed:
Name or service not known.
wget: unable to resolve host address `downloads.openwrt.org'
dpkg: error processing firmware-b43-lpphy-installer (--install): subprocess installed post-installation script returned error exit status 4
Errors were encountered while processing: firmware-b43-lpphy-installer

  • please post the output of iwconfig. – terdon Apr 13 '13 at 18:07
  • @terdon see the modification I've made – Ismail El Harrak Apr 13 '13 at 18:14
  • 1
    Wow, they have made an installer for a network device driver that needs to download something else to install. Smart... OK, I read here (have a look at that site, it is very useful) that the device is supported by the wl module. Try loading it with sudo modprobe wl and then run iwconfig again. Any difference? – terdon Apr 13 '13 at 23:51

According to this page, you should install the broadcom drivrs. If you can connect your laptop using an ethernet cable, open a terminal and run

sudo apt-get install firmware-b43-installer

If you don't have access to a wired connection, get online using whatever method you used to post here and download the installer from here. You can then install it using

sudo dpkg -i firmware-b43-installer_015-14_all.deb

After that, restart and your wireless should work.

| improve this answer | |
  • sorry, but it didn't worked, please see the modification I've made – Ismail El Harrak Apr 13 '13 at 18:34
  • The error is telling you that you need to install another package as well. According to the errors you posted, you need the package b43-fwcutter download it from packages.ubuntu.com and install it as described in my answer. Is connecting your computer with a wire not possible? – terdon Apr 13 '13 at 18:41
  • no, unfutunatly I don't have a wire, I'll try what you said. – Ismail El Harrak Apr 13 '13 at 18:53
  • please see my modifications – Ismail El Harrak Apr 13 '13 at 19:00

For my similar model card, I needed the bcmwl- pkgs, the broadcom-sta pkgs, and the b43 one for it to work.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.