I have just installed a Windows 7 32-bit on my HP Compaq nx6310 notebook. However, once I boot into Normal Mode, I receive 2 Kernel-Processor-Power Event ID 37 warnings in my event log indicating that the performance of my processor is being limited by system frimware but this does not happen on Safe Mode.

Additionally, when I open the Resource Monitor to check my CPU Usage, I notice that the Maximum Frequency is always stuck at 59% instead of 100% and the system is very slow. In Safe Mode, this is always 100% and the system is fast.


new user pic help

What can I do to get a 100% Maximum Frequency on the Normal Mode as well?

Here are my system specifications:

  • RAM: 1024 MB (1 GB) of RAM
  • Processor: Genuine Intel(R) CPU T2300 @ 1.66 GHz Dual Core (Centrino Duo)
  • VGA: Mobile Intel(R) 945 Express Chipset Family (WDDM 1.0)
  • HDD: 160 GB
  • System Model: Compaq nx6310
| improve this question | | | | |
  • Did you check this while on battery power or when the power brick was plugged in? (Many laptops limit CPU speed when on battery power). – Hennes Apr 13 '13 at 22:39
  • @Hennes I always use the AC power as I don't have any batteries equipped. The BIOS does not have any options for power saving or how I control the processor (except for toggling dual core) – Sam Apr 13 '13 at 23:58
  • Thank you for your help. I've fixed this by overclocking as I noticed that the multiplier decreased to 6 instead of 11, so I set it back to 10 and it's now 99%. – Sam Apr 14 '13 at 2:03

The problem was EIST (Enhanced Intel(R) Speedstep Technology) which throttled my CPU speed to avoid high temperature. I found out that it was a software driver which is located at %SystemRoot%\system32\drivers\intelppm.sys. I renamed this driver and restarted, then I was able to get 100% Maximum Frequency (The temperature raised from 50 C to 60 C however)

| improve this answer | | | | |

Its your power settings that is affecting your CPU performance, i have encountered exactly the same problem with my Fujitsu P series laptop. the CPU clock freq was locked at 0.78GHZ and i was worried i tried every thing from reinstalling the drivers to updating the drivers. But i finally found out that i just needed to press a physical button on my laptop to switch back my PC from power saver to high performance mode.

| improve this answer | | | | |
  • 1
    This appears to be an answer to a different question. – DavidPostill Nov 30 '16 at 11:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.