I know that the package is in the repository squeeze-backports, so I added that to my sources.list file.

One apt-get update later, I attempt to use

sudo apt-get -t squeeze-backports install vlc

To no avail. It tells me that I don't have fonts-freefont-ttf, and that it's unavailable. A quick search reveals that it's in the sid repository for debian. Added the sid, another update (which recommended that I install hundreds of upgrades), installed the font. Commented out the sid repository because I didn't want to be bothered by messages for upgrades.

Tried again. This time, the vlc-data failed. Went into aptitude and found that the vlc version listed was the old squeeze one. Went into aptitude -t squeeze-backports. Found the vlc that I was looking for and tried +-ing it in. Turns out that vlc-data is the problem, as it's the original squeeze one and not the newer backports version. Aptitude says that it's UNAVAILABLE for installation as well. Found that the required newer version exists, but for some reason it's not listed in aptitude.

So I manually go to backports and dpkg -i the package to install it. Enter aptitude again and try to install vlc. Now libvlccore is the problem. Aparently it still doesn't recognize vlc-data-2.0.3-1. After a bit of looking, it seems like neither do any of the other packages.

And at this point, I'm stuck. I'm not sure what to do. Any help would be appreciated.

  • tried using synaptic and attempt to fix the issue? Apr 13, 2013 at 22:47
  • @Znau synaptic is just a gui front-end to apt, it doesn't do anything better than cli tools
    – maxxvw
    Apr 14, 2013 at 12:01
  • @maxxvw that being true or not, i have successfully solved issues using synaptic i didn't manage to solve using cli. Apr 14, 2013 at 15:39
  • Nice to see you finding a solution, that's not a clean one but why not...
    – maxxvw
    Apr 14, 2013 at 17:31

1 Answer 1


Debian has a multimedia "branch": link

  1. echo "deb http://www.deb-multimedia.org squeeze main non-free" > /etc/apt/sources.list.d/deb-multimedia.list
  2. apt-get update
  3. apt-get install vlc

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.