I am having issues with accessing my PC via VNC externally. I have read various documentation and forums with people having the same problem, but am still stuck.

I am able to log in to my VNC server through my internal network (192.168.1.xxx).

I am testing the connection via the VNC panel and it prompts this: http://i45.tinypic.com/2ltj8t0.png

Now on my DD-WRT side, I have set up port forwarding. Here is the screen: http://i48.tinypic.com/2nhfi83.png

Any help or tips would be greatly appreciated. I have Comcast as my ISP with a LinkSys CM100 cable modem.

[EDIT] I have an Ooma device in the mix of my router and modem.

  • Have you checked that the port you are forwarding from outside is not blobked by Comcast? – Austin T French Apr 14 '13 at 16:47
  • I am not sure. I tried changing VNC to use ports 1659 and 1559 and port forwarded those two ports on the router via DD-WRT. Still the same issue. I also used this website: t1shopper.com/tools/port-scan – M S Apr 14 '13 at 16:59
  • And that site said those ports were open? I am on another cable ISP, and I have those ports blocked it appears: 98.xx isn't responding on port 1559 (web2host). 98.xx isn't responding on port 1659 (sg-lm). – Austin T French Apr 14 '13 at 17:00
  • Sorry last comment got cut-off. I get the following error: 67.xx.x isn't responding on port 1559 (web2host). – M S Apr 14 '13 at 17:02

You need to find an open inbound port. ISPs block many of them for security (Yours and theirs) on residential lines.

The tool you used to check your ports is useful, but you need to find a good port.

The default MS RDP port is generally open for example: 3389

Then, forward that on your router to your IP and VNC port,

VNC from:3389 to
  • Thanks for the information. It seems like Comcast is blocking a lot of ports (I am doing a 500 port scan from that website). Will post results if I find an open port. – M S Apr 14 '13 at 17:08
  • Most large ISPs do, unless you go with one of their business subscriptions. – Austin T French Apr 14 '13 at 17:13
  • So looking at my setup, I forgot to mention that I have an Ooma (VoIP) system in my configuration. DD-WRT shows the WAN-IP of the Ooma box instead of my Comcast IP...hmmm..maybe this has something to do with it. – M S Apr 14 '13 at 17:27
  • .124 is your Ooma? – Austin T French Apr 14 '13 at 17:35
  • I got it to work! I will post an answer once I have the privilege (need to wait 4 more hours because of S.E. newbie limitation). Thank's for all your help! It wasn't Comcast blocking my ports, but my Ooma device having it's own port forwarding features. So basically I had to port forward from both my router with DD-WRT and my Ooma device. – M S Apr 14 '13 at 19:51

Got it to work. Thanks @AthomSfere for all your help.

The problem was that I have an Ooma set up in my networking configuration. So it is [Modem] - [Ooma] - [Router].

The traffic comes from my cable modem directly to my Ooma first - which has it's own special IP that my router retrieves as WAN (DDWRT). This is 172.27.xxx.xxx.

Now Ooma has its own option to port forward also - thus acting as a router. I had to forward ports 5900 and 5800 from Ooma AND my router.

Below are screen shots of my final configuration.

Ooma - http://imgur.com/wkto3mk

DD-Wrt - http://imgur.com/3Fhndkp

I hope this comes in handy to someone who has an Ooma and has port forwarding issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.