I'm running (via Boot Camp) Windows 7 SP1 on my 32-bit MacBook, and I'm trying to format a new Western Digital My Passport external hard drive to use NTFS. It came formatted of course but I wiped it clean. Disk Management says the drive is RAW, healthy, and primary partition on that hard drive. I just want one NTFS partition, but I can't get Disk Management to do it -- I just keep getting messages saying that the disk is in use. I tried booting into safe mode and formatting the disk there, but that didn't help. Does anyone have any idea how I can get this to work??

  • Have you deleted and recreated the partition and then tried formatting it?
    – Rain
    Apr 15, 2013 at 2:12
  • Yes I have, and it deletes the volume and lets me go through the wizard to create a new NTFS partition. But after working on it for about 10 minutes, I get a message saying "The volume is currently in use. To force the format of this volume, click yes. Warning: Forcing a format might cause unexpected errors in the application that is using this volume. Do you want to continue?" I click yes to continue and about ten minutes later I get an error "The format did not complete successfully". Now I just see the RAW partition again.
    – Jon
    Apr 15, 2013 at 2:28
  • It sounds like the external drive may be DOA. Run a "long test" with SeaTools; dispte being made by Seagate, it works perfectly fine for diagnosing drives of other brands. I believe Western Digital has their own testing utility that you may want to use instead, I do not have a link to it saved though.
    – Rain
    Apr 15, 2013 at 2:38
  • Thank you, I will try SeaTools. I don't think the drive was DOA, though -- before I wiped it, I did successfully use it with WD's own software/utilities. But their software basically took over my computer's resources and in my annoyance at that I decided not only to uninstall the utilities but also to wipe the drive. I'm afraid I messed something up then...
    – Jon
    Apr 15, 2013 at 12:04
  • @Rain I ran the SeaTools long test and it failed...
    – Jon
    Apr 15, 2013 at 20:49

1 Answer 1


Well, I don't know exactly what was wrong, but I fixed the problem:

  1. Booted into OS X
  2. Used Disk Utility to format the hard drive using ExFAT (it worked on the first try; took about 3 seconds)
  3. Booted into Windows
  4. Used Disk Management to reformat the hard drive using NTFS (it worked on the first try; also took about 3 seconds)

That's it. Presto.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.