I was trying to get frames from a video using Xuggle 5.4. The IDE which I use is Eclipse Juno.The last time (which was roughly one months back) when I tried, I got the frames with a gap of 5 seconds, but today when I tried to run the code I got the below error

# A fatal error has been detected by the Java Runtime Environment:
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x000000006ee76520, pid=4340, tid=7344
# JRE version: 7.0_09-b05
# Java VM: Java HotSpot(TM) 64-Bit Server VM (23.5-b02 mixed mode windows-amd64 compressed oops)
# Problematic frame:
# C  [xuggle1062976990104623257.dll+0x736520]  Java_com_xuggle_ferry_FerryJNI_SWIGRefCountedTesterUpcast+0x66f005
# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
# An error report file with more information is saved as:
# D:\Eclipse workspaces\Eclipse Juno\VideoSteganography\hs_err_pid4340.log
# If you would like to submit a bug report, please visit:
#   http://bugreport.sun.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.

When I googled this, I found similar similar problems, but i failed to get any solution or cause for this problem.

What may be the reason for this? I am not able to find the native code which is the cause for the crash. I used to update Java whenever available.

My need is to get the frames from a video file, what other ways are there to get this done? Feel free to ask for detail.


The problem was due to the recent update on Java. When I switched back to the older version, it worked fine without any crashing.

Hope it will be fixed during next update.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.