1

I am trying to install Haskell-2012.4.0.0.exe on my computer running windows 7.

When I run the installer I get the following message and the installation fails,

Installer integrity check has failed. Common causes include
incomplete download and damaged media. Contact the
installer's author to obtain a new copy.

More information at:
http://nsis.sf.net/NSIS_Error

How do I fix this issue and get it to install?

0

The error message suggests what is wrong - incomplete download and damaged media; Get a new copy! For what ever reason, it may appear that your download was not successful (maybe your internet connection dropped during download). So, re-download the installer and then try to install again.

4
  • I used the same installer to install it on another machine running windows 7 and it worked without any issues.
    – Ishan
    Apr 18 '13 at 6:27
  • Well, if you've tried again to install it and it still fails then consider your firewall or AV or any other similar programs (or even permissions)
    – Dave
    Apr 18 '13 at 8:09
  • I have been able to install haskell successfully. I found that changing the usb I used to copy the haskell setup installer from my computer to my usb to install on another computer fixed the issue. It seems that when I am copying the file to the usb, that it is not completely getting copying.
    – Ishan
    Apr 20 '13 at 4:44
  • You didn't mention this in your original post :-)
    – Dave
    Apr 20 '13 at 5:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.