I had my desktop windows 7 computer turned off for several days. After powering back up, it wants to apply "critical" windows updates, so I allowed update and the reboot. Network connections did not work after this, but I didn't check if it was working before the reboot.

Now neither the wireless nor wired connection show up in ipconfig, but they show up (with no error or warning overlay icons) in Device Manager and Network Connections. Ipconfig only shows "Tunnel adapter Teredo Tunneling Pseudo-Interface". Trying to ping anything returns "PING: transmit failed. General failure". Running "ipconfig /release" returns "the operation failed as no adapter is in the state permissible for this operation"

Other laptops, the ipad and phone work with wireless. Plugging the same Ethernet cable into a laptop also works.

I used System Restore to go back 1 and 2 restore points. Neither fixed it.

Booted to safe mode, still nothing in ipconfig.

I also tried the winsock repair suggested here, but this did not help: http://social.technet.microsoft.com/Forums/en-US/winservergen/thread/415e1001-dfe5-47b4-a7b3-4c4642a81c16/

Under Network Connections, the LAN is in Media State "Enabled", but IPv4 and IPv6 Connectivity are "Not Connected". TCP/IP (both v4 and v6) are installed for the LAN connection, and both set to obtain address and DNS server address dynamically.

Anything else I can try to diagnose or fix the problem?

  • So is it correct that both of the Network devices are showing up in Windows, they are just unable to obtain connectivity to the network? – jmreicha Apr 15 '13 at 15:25
  • Sometimes, devices need to be de-energized. Have you tried a complete power cycle? Shut it down, unplug AC power from the unit, wait 5 minutes, then restore power and reboot. – CharlieRB Apr 15 '13 at 17:12
  • Yes, devices show up but do not connect. I had to run out for errands, so unplugged PC, router and power strips for hours. Still no good. – Lost In Code Apr 15 '13 at 20:21
  • Network connection after rolling back in System Restore to about a month ago. Figured this was last resort before a re-install, surprised it worked. – Lost In Code Apr 15 '13 at 22:14
  • I'm glad it worked. Just a small observation: I'm assuming you must've had internet connectivity before updating your Windows, as Windows needs to pull the updates from Microsoft's server. – Rowan Kaag Sep 15 '14 at 21:17

I would remove both adapters from device manager and restart the computer. It should detect the cards and reinstall the drivers for them...Sometimes that's all it takes.

If that doesn't work I'd update the drivers for the cards and the laptop bios/firmware if it's at all out of date.

Another question, when you look at the properties for the NICs is IPv4 showing in the local area connection properties, "this connection uses the following items:" box?

  • Removed from device manager & rebooted. No luck. The IPv4 property is set to "obtain an IP address automatically", not "uses the following items" – Lost In Code Apr 15 '13 at 20:24

Have you tried Windows 7 Diagnose utility? Sometimes it works. Your adapters are basically disabled and you need to enable them. To do so, remove the adapters from the motherboard slots and then start your PC. Shut it down again, plug the adapters back in and boot the system. Hopefully they will start working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.