I am trying to link a file type to an app and it's not working. The file type does not show up in the list of known file types and when I go to "Open With" it does not save the app. This issue is not system wide and only happens with an EU's profile.

  • Which file type and app? "does not save the app" - Did you remember to select the checkbox to set the app as default? What's EU? – Karan Apr 16 '13 at 23:10
  • EU = End User the files type is a .sgm and the app is Multi-Edit – Maasai Mara Apr 17 '13 at 16:34

All information on associated file types is stored in the registry under the HKEY_CLASSES_ROOT Key, as described here.

So your file type has to be there, or the association will not work.
If you don't see your file type under this reg key, something is wrong.

  • The file type is not there on a working machine, .sgm and .sgml dont show up yet I can right click on the file and do a open with and it will open the application.The laptop I am trying to fix I am unable to do that under a users profile but if I log in as my self I can do it. – Maasai Mara Apr 17 '13 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.