I am using LibreOffice 4.0 on Windows 7 and I have noticed that it saves files (for example Writer) with a preview. (The icon of the file shows what's inside it, it looks like a page).

How do I turn it off? I want to to be a normal Writer icon. (A bit like MS Office does, it saves the file with the default icon).

How can I do this?

  • 1
    Most thumbnail previews in Windows are handled by shell extensions. You can hunt for and disable the relevant shell extension with ShellExtView.
    – Bob
    Apr 16, 2013 at 18:39
  • Check out this URL. (It worked for me on Ubuntu 16.04.) superuser.com/questions/726467/…
    – rkdian34
    Apr 27, 2017 at 10:19
  • For a per-document solution, you can uncheck File->Properties->Save preview image with this document. Dec 4, 2023 at 13:39

3 Answers 3


In fact, a LibreOffice feature is the creation of thumbnails, so you could see a "preview" of the contents instead of the Writer icon in file manager. Check for yourself by changing the extension of (a copy of) one LO document to .zip and open the Thumbnails folder.

I don't know if it is possible to disable this feature.

Looking around in Ask.Libreoffice, I found the following:

  • That more details are given here

  • That you can find instructions on how to remove that image in the answers to this question.

In summary:

  1. Rename your file to filename.zip.
  2. Open .zip file and, from within file-roller, peazip or whatever you are using.
  3. Navigate to the folder META-INF and open manifest.xml in gedit or equivalent plain text editor`.
  4. Delete the line

    <manifest:file-entry manifest:full-path="Thumbnails/thumbnail.png" manifest:media-type="image/png">

  5. Back in the main folder of the zip file, delete the folder Thumbnails.

  6. Close and rename back to the original ODF extension.

Note: This is valid for LibreOffice files, irrespective of the OS.

As for the OP's question, is a matter of either disabling the thumbnail preview as suggested in comments or deleting the thumbnail and setting a password so the contents of the file cannot be seen by anybody, depending on what the real needs or desires are.

  • Deleting the line in the manifest.xml (step 4) breaks LibreOffice (vers Calc .ods files - results in error ":1: parser error : Document is empty". But deleting only the Thumbnails folder / thumbnail.png file works. FYI, the thumbnail images for my files have bloated to 50k - 60k, doubling (or more) the size of some files. A new spreadsheet with 30 rows by 4 columns with just 1 or 2 words per cell saves a 54,301 byte .ods file, 47k of thumbnail, removing the thumbnail leaves just 7099 bytes of .ods. Valentin's answer - built-in option to stop saving these is +1
    – Xen2050
    Jun 17, 2015 at 21:36
  • This post shouldn't be selected anymore. Valentin's one provides the exact way to prevent thumbnails to be generated.
    – mins
    Nov 25, 2018 at 11:30

Take a look at the answer here of LibreOffice configuration.

According to the post, the choice of saving a preview thumbnail is a setting that you can change:

    Tools → Options... → LibreOffice → Advanced → Expert Configuration

Select the preference named: org.openoffice.Office.Common/Save/Document/GenerateThumbnail

Double clicking on it toggles the value to false.

  • Welcome. Your answer is just a link to an external answer. If that site is unavailable, your answer would provide nothing of value. In addition to the link, summarize the key points of the solution so someone can solve the problem by reading your answer, and the link serves as "further reading" and attribution. Notice that the accepted answer (which got 4 upvotes), was similarly based on a solution found somewhere else. That's a good example of how to write a high-quality answer that gets recognized. BTW, even after an answer is accepted, other good answers can get upvotes.
    – fixer1234
    Nov 19, 2014 at 23:13
  • 2
    This should be the selected answer. It does exactly what the question asks for.
    – mins
    Nov 25, 2018 at 11:22
  • this answer is perfect for me Jan 25, 2021 at 17:35

While this is not strictly speaking an answer to the original question (because unix shell scripts won't work on Win7, unless you install Cygwin from http://www.cygwin.com), I had the same problem, and came up with a trim-odt shell script that removes the thumbnails from libreoffice documents, at https://github.com/fourmond/utils.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .