7

I have a Dell Studio 17 running Windows 7 64bit. It's been fine for years but a month or two ago I noticed that when I have an external monitor plugged in, if I try to use the built-in touchscreen all touches go to the external monitor. The touchscreen works fine when no external monitor is connected in both Win7 and Win8. (I have not tried it in Win8 with an external monitor.)

I also have a Mimo touchscreen USB monitor that works fine. Whether it is connected or not appears to have no influence on how the built-in monitor behaves.

I have looked at the touch settings in the Tablet PC Settings applet but can't seem to fix it there. The display options in that applet list all monitors. I select Mobile PC Display and tell it to calibrate, the calibration form comes up on the laptop display but when I touch it to calibrate all the touches go to the external monitor so calibration doesn't work.

7

I had written up this question and was experimenting before I posted it in anticipation of what I thought you all might suggest I try. I'm pleased that that experimentation led to a solution. I'll post it just in case someone else has the same problem.

On the Tablet PC Settings applet there is a Setup button. When you click it the internal screen changes to a "touch this screen or hit enter if this is not a touchscreen" message. I had tried this once before but since the touches went to the external monitor I wasn't able to complete it. This time I used the mouse to click on the form when it showed on the internal monitor. Then when it showed on the external monitor I hit enter to indicate it isn't a touchscreen. That fixed the issue.

I have no idea how the laptop got into that weird mode to begin with since I'm very certain I've never run that Tablet PC Settings applet before.

Now if I can just figure out why the touchscreen generates phantom touches under Windows 8...

0

And if that doesn't help, try this: click the Windows icon, go into Settings, go to Display at the top left, choose which monitor is the touchscreen, highlight it, then scroll down to Multiple Displays and click Make This My Main Display. Best wishes all!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.