3

I use Cygwin running under Windows XP to make an X Windows ssh connection to a RedHat server.

I’ve run a few applications through the Cygwin/X interface, and they perform fine. However, the main application I use is Eclipse for C/C++ development (using Eclipse CDT). Unfortunately, Eclipse has some noticeable delays when running through Cygwin/X:

  • After pressing Ctrl+F to open the Find/Replace dialog, the dialog opens quickly, but it can take up to 5 secs before the dialog becomes responsive to keystrokes. The edit box on the dialog behaves as if it is disabled during this time. If you type while the dialog is unresponsive, the keystrokes are buffered because they type out once the dialog starts responding.
  • Opening source files is fairly quick, but closing the file tab can take up to 5 secs.
  • Switching between the C/C++ and Git perspectives can take 5 or more secs. All these delays are not typical of how Eclipse should behave.

Here are some tests I’ve run to track down the problem:

  • I’ve made several recommended changes to eclipse.ini. There was some improvement, but nothing major. The problem does not appear to be Eclipse (see next test).
  • I walked over to the RedHat server, signed in as my account, and ran Eclipse. Closing tabs and using the Find/Replace dialog has no delay. Yippie! Too bad I can’t be directly signed into RedHat on a daily basis.
  • I ran x11perf and it implies that being directly on RedHat is slower. That’s strange since running Eclipse directly on RedHat is objectively much faster. So, I can only assume the x11perf results from different X servers can’t be compared with each other.

Based on what I’ve seen, I think the problem is networking related. FYI: The network security on this private network is very tight, but I don’t know the details without talking to an admin.

I start the Cygwin/X session with this xinit command: C:\cygwin\bin\run.exe /usr/bin/bash.exe -l -c /usr/bin/xinit.exe My .xinitrc contains: xhost + xterm -e ssh -Y 192.168.1.2 /usr/bin/gnome-session

Here’s some version info:

  • FYI: I’ve tried two version of Cygwin/X. I’ve tried X Server versions 1.10.1 and 1.13.1. The ssh version are “OpenSSH_5.8p1, OpenSSL 0.9.8r 8 Feb 2011” and “OpenSSH_6.1p1, OpenSSL 1.0.1c 10 May 2012”
  • On RedHat the X Server version is 1.1.1 and X11 is Release 7.1.1. The ssh version is “OpenSSH_4.3p2, OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008”

What tests can I run to try and isolate the problem?

Are there some other applications I can run to see if they exhibit the same slow behavior?

Do you think network settings are causing the problem?

0

You can try this:

  • enable SSH compression (adding -C to the ssh command), although this may make it even slower
  • enable verbose mode (adding -v) and look for any errors or warnings
  • use another SSH client, like Putty (also with or without compression and check the Event Log)

You should try applications like OpenOffice or any other ones with lots of windows and widgets.

  • Adding -C may have helped ever so slightly (but not enough). Adding -v spits out more messages, but nothing significant. There are a couple warnings, which I'll try to post if people think they'd be useful. The problem only occurs with X Windows connections. A Putty console window runs without problem. I can't get OpenOffice installed on this RedHat server. I'll see if there are other X applications I can try. – Dean Hill Apr 24 '13 at 17:12
  • did you use putty just for a console or did you use its X Window tunneling? – golimar Apr 25 '13 at 8:25
  • Firefox would be another one to try, have you tried it already to see how it performs? – Ken Williams Jun 2 '14 at 14:25
0

Use Eclipse Remote System Explorer and create ssh connection.

Or use NetBeans IDE: C and C++ Development

In NetBeans already have ssh connector and much more ...

  • Thanks for the suggestion, but I need to run Eclipse directly on the server. That is why I launch an X Windows session. – Dean Hill Apr 24 '13 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.