1

Cant get Appache run on my Windows Server 2012 because there is an application already using this port. But which application?

I found out that the Port is used by "system" .. and in this article it says the port is mandatory for WS2012 Essentials. http://www.sbsfaq.com/?tag=windows-server-2012-essentials

So, what are the best practices to cope with this problem ?

Anyon who can help me out ?

  • What other roles and features do you have installed on the Server 2012 box? – jmreicha Apr 17 '13 at 16:39
  • Only thing might be conflicting is media-server? Roles: admin, standard. – Sven Koluem Apr 17 '13 at 17:33
  • Are you using IIS on this server already? Or any inbuilt Web server roles apart from XAMPP? – Zeeshan Apr 17 '13 at 17:42
  • @SvenKoluem a media server could absolutely conflict depending on how you have things set up. Check to see if IIS is enabled. – jmreicha Apr 17 '13 at 17:49
2

Use this command: netstat -o -n -a | findstr 0.0:80 to check the PID of the process using port 80. If port 80 is free, nothing will appear in result. If any process is running on port 80, you will get its details. enter image description here

Now you can check from task manager the process running under this PID. enter image description here

To cope with this problem either:

  1. Kill the process which already uses port 80 if it is unnecessary
  2. Make necessary changes for this other process to shift it to some other port
  3. Run apache (XAMPP) on any other port, except port 80.

To change the port in apache, open httpd.conf file (present in your XAMPP installation directory) and modify this line: Listen 80 to whatever port you find suitable. Usually 8080 is used in case 80 is busy (8080 may be busy as well, you need to test for a port which is free and good to use using the command given above).

| improve this answer | |
  • It uses Port 443 .. don't know why appache should use 443 and not 80.. ? – Sven Koluem Apr 17 '13 at 16:52
  • 443 is used for https (http secured), 80 is used for http. HTTPS URLs begin with "https://" and use port 443 by default, whereas HTTP URLs begin with "http://" and use port 80 by default. You can edit the line Listen 443 in your httpd.conf file to a suitable port, and yes, you will need to restart Apache service whenever you make changes to httpd.conf file for the changes to take effect. – Zeeshan Apr 17 '13 at 16:58
  • 18:32:06 [Apache] Port 443 in use by "system"! 18:32:06 [Apache] Apache WILL NOT start without the configured ports free! -- And there is nothing about 443 in httpd.conf – Sven Koluem Apr 17 '13 at 17:07
  • Well, try checking which process is it from the task manager (enable PID column first from View > Select Columns). If it is svchost.exe, right click on it and select "Go to service(s)" option to view the services using it. – Zeeshan Apr 17 '13 at 17:09
  • ok it is pid 4 .. and it belongs to "system" :( – Sven Koluem Apr 17 '13 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.