I recently upgraded my graphics card from an XFX Radeon HD 6850 1GB to an MSI Radeon HD 7850 2GB. (Windows 8 x64)

The TV is a Vizio E500i-A1

My HDMI audio output used to work fine with my TV, but when I upgraded my graphics card I can't get HDMI audio to work. 6 different HDMI audio outputs (there used to be only one) show up in the sound manager, but all of them show up as being disconnected.

And CCC says that my display doesn't support audio when I know for a fact that it does.

What can I do to fix this?

Also, it might be worth mentioning that the Sound Manager takes a lot longer to open than it used to. After I click on Playback Devices it takes about 30 seconds to open.

Update: I tried reinstalling all my graphics drivers, including the AMD HDMI Audio Drivers. That fixed the issue for a few hours and then it stopped working. Today I tried doing it without installing the AMD HDMI audio drivers and the same thing happened; it worked for an hour and then the TV starts showing that it doesn't support audio.

The differences are that when the AMD HDMI Audio Driver isn't installed my Sound Manager doesn't take a long time to open anymore and names of the devices are different. (Digital Audio (HDMI) instead of Digital Display Audio) pictured below:

I need to get this fixed, the audio from my TV has to start working, so I'm opening a bounty.

  • When you upgraded your drivers, did you also select to install/update the "AMD HDMI Audio Drivers"? – Lennart Apr 18 '13 at 11:03
  • They're part of AMD Catalyst, you can't update them seperately – Mark Kramer Apr 18 '13 at 13:40
  • You can select/deselect them when installing Catalyst: verrytechnical.com/wp-content/uploads/2011/06/… – Lennart Apr 18 '13 at 15:37
  • I'll retry it, but that's an ATI install manager, it's all AMD now. – Mark Kramer Apr 22 '13 at 16:39
  • Actually, I was wrong, nothing fixes the issue. I tried reinstalling my graphics drivers alone with AMD HDMI Audio drivers and that fixed it momentarily, but it stopped working after a few hours just like it did when I first installed the card. And the same thing happens even if I don't install the drivers. I'm lost now. – Mark Kramer May 6 '13 at 2:11

I solved this by uninstalling the audio devices using Device Manager.

  1. Open Device Manager from the Control Panel.
  2. Expand "Sound, video and game controllers".
  3. Right click and uninstall all "High Definition Audio Device" items.
  4. Restart the computer and the devices should auto reinstall.

Another step that i initially tried that didn't appear to work but might be required. In device manager menu View > Show hidden devices. Expand Audio inputs and outputs. Uninstall the items having the problem.

  • This just happened to me again. I recently updated my graphics drivers so I think that is what causes it. After following my steps above it now appears in device manager as "Intel Display Audio". – Nicholas Aug 4 '13 at 2:28
  • I'd like to say that this solution worked for me. I don't know exactly what happened to the audio drivers... I was swapping my graphics card with another computer for testing, swapped back and my HDMI stopped showing up as an audio device. I uninstalled the audio drivers through Device Manager; they auto re-installed upon reboot, and everything worked again. I believe this may be an AMD Catalyst-specific issue, but I can't be certain. – Chris Cirefice Jul 21 '14 at 22:56
  • 1
    A friend of mine, let's call him "Albert," had a very similar problem with his old Gateway hooked up to an even older Dynex HDTV. He had video on it, but just to be safe, I used my laptop to search this site. I went through your 4 steps on his computer and restarted, that didn't work. In the Device Manager, I checked View > Show hidden devices, but that didn't fix the problem. But this gave me an idea: what if I right-click in the Sound control and there is some kind of "Show disabled devices" option? Albert has never been happier to hear iTunes blasting the Scherzo of Bruckner's Symphony! – Robert Soupe Sep 19 '14 at 17:48
  • @Nicholas So this worked for me, but every time I restart my PC the problem comes back and I have to uninstall the drivers again. Very annoying. Any ideas? Asus N550jk running Windows 8.1 – ACD Sep 30 '14 at 0:15

Things to try:

  1. Get a high-quality HDMI cable
  2. When the problem happens, disable and re-enable the ATI HDMI audio
  3. Update Chipset driver and BIOS (if available)
  4. Uninstall both the ATI HDMI Audio and the RealTek High Defintion Audio in the Device Manager (do not check the box to uninstall the drivers) and reboot.
  • This will take a few days to fully test, since the issue only seems to happen after I don't use my computer connected to my TV for a few hours. It's not the cable, it worked with my 6850. – Mark Kramer May 6 '13 at 8:38
  • It can happen that a new video card is more finicky on cable quality (although I agree that the chances are slim that the problem is with the cable). – harrymc May 6 '13 at 9:25
  • But if it was the cable, it wouldn't work for a few hours and then stop working, it wouldn't work at all =p I'm gonna see about updating the Bios but I checked the support page for my motherboard and there's nothing new to download there – Mark Kramer May 6 '13 at 12:55
  • I think it might be working, although I have no idea what fixed it. – Mark Kramer May 8 '13 at 7:46
  • It is sometimes said that disable/re-enable of HDMI audio fixes the problem for some time, to be repeated when it reoccurs. So next time apply the fixes one-by-one to find out which one did it. Also, did you reseat the cable? – harrymc May 8 '13 at 8:06

You should try deleting all of your audio output profiles, and either creating a new one, or let it create a new one for you. Also, make sure that your volume is up, and your sound card is on. Make sure that you restart your computer as well.

If this by chance is your TV, try changing the input setting (Ex. HDMI1, COMPONENT). Also, unplug your TV and replug it in.

This very well could be your TV, and not your computer at all. Try connecting some other audio input device into your TV (Ex. VCR) and see if it still doesn't work. If it works, its your computer. If it doesn't, its your TV. HDMI cable disconnection is possible. Check that the HDMI cable is firmly placed in your TV, and that its connector is not broken.

If you receive a picture on the TV from either the computer or something like a VCR, it is probably not the HDMI cable.

Hope one of these methods works.

  • I know it's not the TV, it worked before and I use many other devices besides my computer with it. Who uses VCRs anymore anyway? I also know it's not the HDMI, I tested it with two other ones. It's definitely the computer, I'll try reinstalling my audio drivers – Mark Kramer May 7 '13 at 14:03
  • Okay, yeah, its probably the audio drivers (or whatever encodes the audio and video into the hdmi port). Also, see if your computer can make sound on its own (Ex. in-computer speakers, or audio jack connected to speakers). If it can make noise on its own, then it is probably not an audio driver problem. At that point, it is probably an hdmi problem (drivers, hardware, etc...). – HelpingHand May 7 '13 at 14:36
  • You should probably check my above comment before you go reinstalling the drivers. It may tell you that the audio drivers are not the problem. – HelpingHand May 7 '13 at 14:40
  • Yeah I know they're not, my surround sound and my computer speakers both work fine. But it's the only option left I can think of. I can't find any device for what controls the HDMI on the video card. And using The AMD HDMI Drivers or not the same thing happens. – Mark Kramer May 7 '13 at 15:31
  • I think I just found it. It would look something like this: HDMI Card – HelpingHand May 7 '13 at 15:35

I'm going to list the various troubleshooting steps I took and what the result was:

  • Restart Computer: No difference
  • Reinstalling my audio drivers (Realtek HD Audio): No difference
  • Tried with and without AMD HDMI Audio Drivers: No difference
  • Update Chipset and BIOS driver: No updates available
  • When the problem occurs try to disable/reenable AMD HDMI Audio Drivers: No difference

Whilst trying to fix this problem I encountered another problem with my video card, outlined in this question.

When I finally fixed that issue, the problem in this question wasn't fixed. But then I upgraded to the beta version of the drivers for my video card and installed using the method I outlined in my answer on that question, and I took my HDMI cabled out of the TV and plugged it back in and that seems to have worked.

So, what I think it is: Upgrading the video card drivers.

Some people suggested upgrading the sound drivers or the chipset drivers or the BIOS, but the HDMI port is on the video card, it uses its own drivers that are included with the video card. That's why I think it finally worked when I updated my video card drivers to the latest beta version. I did that about 4 days ago and haven't experienced another problem since.

Note: It appears that the HDMI sound drivers are completely independent from the normal sound drivers. My Realtek HD Audio Manager has no control over my HDMI connected TV.


I fixed this same issue (although I only had one duplicate HDMI audio device appearing in playback devices) by first selecting the real HDMI audio device in Windows Playback Devices (right click the volume icon in the system tray and choose Playback Devices) as the default audio device.

I chose the HDMI audio device at the top of the list and set it to be the default audio device by right clicking it and choosing the option to do so. If the option is greyed out, it means it's not a real device or nothing is connected (or recognised as being connected) to the port.

In this case, the system had an AMD E-350D APU with Radeon HD 6310 graphics on Windows 8 64-bit and running version 13.9 of the Catalyst driver.

The Catalyst control centre still reported that the device (a Toshiba 42HL833B LCD TV) did not support audio, even though this was evidently not true as the computer audio was currently being output by it. This "cosmetic issue" was fixed by downloading a later version of the Catalyst driver (version 13.12) and when installing it, choosing to do a custom uninstall of the existing drivers prior to installing the newer drivers. In the custom-uninstall options, I selected to uninstall the AMD HDMI Audio driver. After this task completed, the duplicate HDMI audio device was no longer present, yet sound continued to function ok from the real HDMI audio device which was still selected as the default device. The current version of the specific HDMI audio driver in Catalyst version 13.12 is


I had the same problem with Catalyst 13.4. When it was installed, it worked for a few hours.

I solved it by installing Catalyst 13.8 beta, I don't have this problem anymore. I'm quite sure it is only a Catalyst problem.

I use Windows 8 64 enterprise, Asus P6T, Realtek HD audio driver installed too. I thought of many things, like Realtek incompability, but I was wrong.

So, change Catalyst versions, it will work.

Edit: Install this file too: ATI HDMI Audio Device R2.70 (2012/6/22/ 22630k) It is on Realtek.tw website , go to download Software: Drivers & Utilities, High Definition Audio Codecs, it is there. Download it and install it. It will not overwrite your RealTek software, don't worry. Reboot system. It worked for me, at least, I don't have this problem anymore.


So catalyst 14 beta caused this problem for me.

I uninstalled two versions of Audio driver in sequence to fix the problem. First there was the ATI....... driver then it was replaced with another generic driver which I also uninstalled. Finally my computer reverted to a set of older drivers which work great.

Sorry if this does not make sense... I rather enjoyed the scar from banging my head against the wall.

This worked for me but if need Realtek as more Audio drivers.


Go to properties of the TV speaker and change levels . stupidly the level is at zero and thats why there was no sound .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.