Have a Radeon 5xxx mobility on a HP notebook. (Not switchable graphics)

Today I was updating the AMD driver to the 13.1 mobility driver for Win7 64bit.

Then it crashed in the middle and did some minidump.

After that, I tried installing the driver again.

Didn't work.

Went into Device Manager and clicked update driver - it installed a 2011 driver for me. Then now, I go into the start menu and click "Catalyst Control Center", and it says "No AMD Graphics Driver is installed, or the AMD Driver is not functioning properly. Please install the AMD driver appropriate for your hardware".

Any solutions? I think the best way is to install the last 12.xx (what number is it?) catalyst mobility driver for win 7 64 bit (which was what I had previously) but I can't find it anywhere on the internet (including AMD's whole website). Can someone help please? Thanks in advance

  • Have you tried to rollback the drivers from the device properties window, driver tab? – CharlieRB Apr 18 '13 at 15:01
  • yes, that option is grayed out. – GOGOGO Apr 18 '13 at 15:02
  • instead of trying in AMD site, go to [hp.com](www.hp.com) select your country and go to support->download drivers. Enter your laptop's product number and proceed to download drivers from that page. – MAKZ Feb 15 '14 at 9:26

You can try a System Restore to rollback to a previous checkpoint.


Try a clean Uninstall of your AMD drivers by using the supported tools.


Then restart and reinstall the latest driver.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.