5

How do I make Remote Desktop Connection in Windows 7 (Professional) use my current domain credentials, instead of prompting me for them, by default. This used to be setup, but when I recreated my Active Directory domain and reinstalled Windows this feature seemed to stop happening.

For reference, both machines are connected to the same domain. The server I'm trying to connect to is running Windows Server 2008 R2.

2

Before you start, ensure that your server is configured to allow Single Sign-On (SSO). If you have a Remote Desktop Session Host, the Always Prompt for Password setting should not be set for the connection in Properties>Log on Settings and also on the General tab, the Security Layer should be set to Negotiate or SSL.

Also, SSO needs to be enabled on your local / domain policy. Check the value of Allow Delegating Default Credentials here in your GPO:

Computer Configuration\Administrative Templates\System\Credentials Delegation

Also ensure that your server (TERMSRV/) is added to the server list, if required. You may use wild card characters to add multiple server names

When you run the Remote Desktop Connection, you should tick the box for Allow me to save credentials.
enter image description here

You will then be prompted to enter your credentials. When you do so, ensure you tick the box for Remember my credentials. Your credentials should then be saved, and next time you log in it will be passed through.

enter image description here

Here is a link with some basic step by step instructions: http://itowns.blogspot.co.uk/2011/06/enabling-remote-desktop-connection.html

  • 6
    If you're asked for credentials by Remote Desktop, then you haven't successfully set SSO - even if you "remember" your credentials. That's kind of the whole point of SSO. The above screenshots are junk; they SHOULD look like this: i.imgur.com/JQbVaFN.png – James Johnston May 24 '16 at 2:44
2

On the Server do the following steps:

  1. click Start
  2. point to Administrative Tools
  3. point to Remote Desktop Services
  4. click Remote Desktop Session Host Configuration
  5. under Connections, right-click the appropriate connection (for example, RDP-Tcp)
  6. click Properties
  7. in the Properties dialog box select the General tab
  8. verify that the Security Layer value is set to either Negotiate or SSL (TLS 1.0)
  9. select the Log on Settings tab
  10. ensure that the Always prompt for password check box is not selected
  11. click OK.
  • This is exactly what I was stating too, but it only addresses the server side, and is specific to RDS, which may or may not be relevant here. – RoKa Apr 19 '13 at 14:13
  • You still need to set a GPO on the client computers to allow Kerberos delegation; see @RoKa's answer. – James Johnston May 24 '16 at 2:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.