When I try to launch "Remote Desktop Connection" in win7 ultimate 64 I get the following message:

The Remote Desktop Services ActiveX control (mstscax.dll) does not match the version of the client shell.

It worked the other week when I last used it and I haven't knowingly done anything to the computer.

this is the error message

  • Is that error from the client when you connect, or from the server after you connect? Apr 19, 2013 at 14:38

3 Answers 3


somehow a different version of this mstscax.dll is now resident in the system32 folder. go to the system32 folder, find the mstscax.dll right click on it go to properties go to previous version, wait for it to finish the search, if you see one, then this is going to replace the existing one. but before you can do that you must take ownership of the mstscax.dll file that's not working in order to rename it to mstscax.old, so you will go the security tab and do whatever it takes to take ownership of the file. once renamed and you copy and paste the one you found in the previous version tab you will be able to launch rds again.


I had the same problem and it seems that a windows update package broke the RDP client. I found out that the file mstsc.exein the folder system32 had been modified lately, and after some research that Windows updates had been installed on the very same day. So I tried uninstalling all updates performed on this day using Programs and Featuresin the control panel (in my case, KB2857650 and KB2830477). After restarting my computer, I could again use the remote desktop client normally.


we had this problem to and the doscommand "sfc /scannow" fixed our problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.