I have Internet access through a student residence network (via a jack on the wall). I want to connect it to a router to be able to connect both a laptop and a mobile phone (my residence only allows a single MAC address per room). I can use for instance Connectify, but I'd like to avoid having the computer on to be able to connect my phone.

I can connect the router, clone my MAC and it almost works: both computers can access the Internet. However, the university's website (which I'll call www.example.com from now on) becomes inaccessible in this case: I cannot access it by name (nslookup returns "Can't find www.example.com: No answer"), and if I try to access it by IP (obtained via nslookup when not using the router, and defined as 10.f.g.h, in the local network), I have an error reported by a TYPO3 page: Page Not Found. Reason: RealURL error: unable to determine rootpage_id for the current domain.

I'd like to both understand: (1) what TYPO3 is doing in this case, and for instance if there is a URL which I can use to take me to the "standard" www.example.com website; and (2) if there is a way to tell my router to obtain the DNS result just as my computer does when it is connected directly to the wall. I believe this should be possible, since using Connectify allows me to do it: my phone can access www.example.com even though its DNS server is reported as the laptop.

I already tried most if not all DNS settings on DD-WRT. For instance, enabling local DNS and setting it as the value obtained by my computer. I tried using OpenDNS, but it is blocked in my local network. Google's public DNS is not blocked but I couldn't make it work either.

This question has been cleaned and reformulated. Some additional (possibly useful) information can be found below.

Using isitup.org, I can see the external IP reported for www.example.com is different from the one I obtain when inside the residence network, and this external IP is not accessible from the residence.

Full results for some tests using nslookup:

When connecting without router:

% nslookup www.example.com
Server:     10.4.a.b
Address:    10.4.a.b#53

www.example.com canonical name = restypo01.example.com
Name:   restypo01.example.com
Address: 10.5.x.y

When connecting with router (router's IP is

% nslookup www.example.com

*** Can't find www.example.com: No answer
% nslookup restypo01.example.com

*** Can't find restypo01.example.com: No answer

My router's DNS server is the same obtained when connecting without router: 10.4.a.b.

Edit: partial solution

I managed to add a special DNSMasq rule on my router that seems to work, at least for specific subdomains:


To get the exact IP addresses, I had to connect the computer without the router, retrieve the IP addresses of these domains (as seen from the internal network), and then I added these rules to the router, and now at least for these websites, it works.

However, these domains has several subdomains, so it becomes tedious to add each of them manually. I'd like them to be found automatically, just as when there is no router between my computer and the wall jack. Any ideas?

  • It seems that your router is not configured to forward DNS requests. In the router configuration, set the DNS servers to the same address as you would see without the router. – Wolfizen Apr 21 '13 at 23:58

Maybe your university network is a local network, and not accessible for the outside world? Maybe your router uses a dns server that's outside the local network? Is it different from the one your laptop uses?

I've seen something like this happen in trains with wifi. I use dnscrypt and Opendns as dns-server. When in a train I cannot connect to the login page of the train network. When I disable dnscrypt, I can login. This means that opendns has no knowledge of the train network and its dns. So I make a connection to the train router, but dnscrypt tries to connect to opendns, which is not available. Then I cannot connect to the train homepage to login to the network to be able to connect to internet.

This is probably a different situation, but I hope to explain something that will help you look further.

  • I believe so, I just edited my question to include this information: the reported IP address is different when seen from the outside or the inside. I'd just like to know how to "prevent routing" for such addresses, which might let them become accessible from the "inside with router". Is there a way? – anol Apr 20 '13 at 16:44
  • 10.x.x.x is always intranet, not accessible for the outside world. The DNS-admin of your university could link the subdomain to this internal address, and that would make it work with external dns-servers, but there is no need to do this when the internal dns-server handles all traffic. What is the ip of the dns-server when you connect directly with your laptop (in the laptop dns-settings), and what is it when you connect the router (in the router dns-settings)? – SPRBRN Apr 20 '13 at 21:32
  • In both cases, the DNS server (same as the DHCP server) is the same: 10.4.x.x. The default gateway is 10.133.x.x and the subnet mask is – anol Apr 21 '13 at 13:25

Hmmm... one MAC address on the network... maybe let your router be that device. Clone the registered MAC address in your router and let it be the device the example.com network sees. Run NAT on your router as it appears you're doing. Let the router handle the DNS requests to the example.com DNS servers and configure your devices to query the router (not the example.com DNS servers) for DNS requests. As long as your router can act as DNS cache and forwarder this should work as my guess is that their DNS server is configured to only respond to queries from IP addresses directly on the example.com subnet so the request cannot come from your NATted addresses (192.168.etc.). This way both devices (and more) can be active at the same.

I'm almost willing to bet that they are fscking with the TTL as I mention in the comments.

  • Of course your devices should not use the registered MAC address. – user168261 Apr 21 '13 at 22:53
  • Just to add that this is pretty normal setup for such a router. Just like at home when your ISP gives you one address yet you can have many inside addresses. And it's common if not typical for the router's DHCP server to assign its own inside (NATted) IP address as the DNS server for the clients. – user168261 Apr 21 '13 at 22:56
  • The only way they could actually tell that you use such a setup (and they probably don't even attempt it) would be via TTL's or sequence numbers. If that's the case you could work around that by resetting the TTL's (they get decremented at every device) and/or randomizing the TCP sequence numbers (OpenBSD as a router can do this). – user168261 Apr 21 '13 at 23:10
  • Thank you, I'll try using NAT with DD-WRT and see if it works. This is the kind of solution I had in mind initially. – anol Apr 22 '13 at 13:47
  • I tried checking some settings in my router but couldn't make it work. I tried using DNSMasq, tried several configurations, but still nothing. I'll see if there are other things to try, but I' m – anol Apr 23 '13 at 12:35

If you can access "normal" websites it means that your NAT and DNS forwarding are working OK.

Didn't you maybe set the local network name on the router to example.com? On your computer do a ipconfig in a command prompt and check what it says for "Connection-specific DNS Suffix". If it's example.com it would cause your computer to look for www.example.com in YOUR local network, and not find it.

  • Hum, it seems you are on the right track, there's a "res.example" connection-specific DNS suffix when using ipconfig. – anol Apr 26 '13 at 19:35
  • I followed Microsoft's instructions on setting the connection-specific DNS suffix, ipconfig indicated it was set, but still the same result: cannot access local websites. – anol May 1 '13 at 8:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.