With the default settings, command + arrow_left switches to the tab on the left. How to change it so that it puts the cursor at the beginning of the line instead ?


From https://stackoverflow.com/questions/6205157/iterm2-how-to-get-jump-to-beginning-end-of-line-in-bash-shell:

  • Go to settings (Command + ,)
  • Go to tab keys
  • Under "Global shortcut keys"
  • Change entry Command + left arrow to Send Hex code: 0x01
  • Change entry Command + righy arrow to Send Hex code: 0x05
| improve this answer | |
  • 2
    You can also set up Option+arrow keys to jump words by setting up Option + left arrow to escape sequence and key b, and Option + right arrow to escape sequence and key f. – Jamon Holmgren Sep 22 '13 at 23:33
  • @JamonHolmgren - I can't see escape sequence in the menu, the menu is huge! which sub-section is it in? – Toni Leigh Oct 19 '15 at 11:39
  • @ToniLeigh Just scan down until you start seeing "Send..." items. It's in there. – Jamon Holmgren Nov 12 '15 at 0:16
  • Here's a link to a screenshot: cloud.githubusercontent.com/assets/1479215/11107105/… – Jamon Holmgren Nov 12 '15 at 0:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.